summaryrefslogtreecommitdiff
path: root/FreeBSD
diff options
context:
space:
mode:
authorVasudev Kamath <kamathvasudev@gmail.com>2012-12-13 22:38:45 +0530
committerVasudev Kamath <kamathvasudev@gmail.com>2012-12-13 22:38:45 +0530
commit658e20cded80a08d097b7833afbe3b20ee9aa39b (patch)
treeee1e275637edfbb359ad856d04ecbe807bd39db3 /FreeBSD
Imported Upstream version 2.8.3
Diffstat (limited to 'FreeBSD')
-rw-r--r--FreeBSD/textproc/ctpp2/Makefile25
-rw-r--r--FreeBSD/textproc/ctpp2/pkg-descr7
-rw-r--r--FreeBSD/textproc/ctpp2/pkg-plist72
3 files changed, 104 insertions, 0 deletions
diff --git a/FreeBSD/textproc/ctpp2/Makefile b/FreeBSD/textproc/ctpp2/Makefile
new file mode 100644
index 0000000..061e94f
--- /dev/null
+++ b/FreeBSD/textproc/ctpp2/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ctpp2
+# Date created: 25 Jan 2008
+# Whom: reki@reki.ru (Andrei V. Shetuhin)
+#
+# $FreeBSD: ports/textproc/ctpp2/Makefile,v 1.27 2010/08/04 07:44:02 lwhsu Exp $
+#
+
+PORTNAME= ctpp2
+PORTVERSION= 2.8.3
+CATEGORIES= textproc devel
+MASTER_SITES= http://ctpp.havoc.ru/download/
+
+MAINTAINER= reki@reki.ru
+COMMENT= C++ library to use templates in C/C++ projects, version 2
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+USE_ICONV= yes
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAN1= ctpp2c.1 ctpp2vm.1 ctpp2i.1 ctpp2json.1 ctpp2-config.1
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/textproc/ctpp2/pkg-descr b/FreeBSD/textproc/ctpp2/pkg-descr
new file mode 100644
index 0000000..f8d9566
--- /dev/null
+++ b/FreeBSD/textproc/ctpp2/pkg-descr
@@ -0,0 +1,7 @@
+This is a simple set of C++ classes which allow to use
+templates like perl modules Template Toolkit and HTML::Template::Pro
+Version 2.
+
+WWW: http://ctpp.havoc.ru/
+
+- reki@reki.ru
diff --git a/FreeBSD/textproc/ctpp2/pkg-plist b/FreeBSD/textproc/ctpp2/pkg-plist
new file mode 100644
index 0000000..3ad1b9f
--- /dev/null
+++ b/FreeBSD/textproc/ctpp2/pkg-plist
@@ -0,0 +1,72 @@
+bin/ctpp2-config
+bin/ctpp2c
+bin/ctpp2i
+bin/ctpp2json
+bin/ctpp2vm
+include/ctpp2/CDT.hpp
+include/ctpp2/CDTSortRoutines.hpp
+include/ctpp2/CTPP2BitIndex.hpp
+include/ctpp2/CTPP2CharIterator.hpp
+include/ctpp2/CTPP2Compiler.hpp
+include/ctpp2/CTPP2DTOA.hpp
+include/ctpp2/CTPP2Exception.hpp
+include/ctpp2/CTPP2Error.hpp
+include/ctpp2/CTPP2ErrorCodes.h
+include/ctpp2/CTPP2FileLogger.hpp
+include/ctpp2/CTPP2FileOutputCollector.hpp
+include/ctpp2/CTPP2FileSourceLoader.hpp
+include/ctpp2/CTPP2GetText.hpp
+include/ctpp2/CTPP2GlobalDefines.h
+include/ctpp2/CTPP2HashTable.hpp
+include/ctpp2/CTPP2JSONFileParser.hpp
+include/ctpp2/CTPP2JSONParser.hpp
+include/ctpp2/CTPP2Logger.hpp
+include/ctpp2/CTPP2OutputCollector.hpp
+include/ctpp2/CTPP2Parser.hpp
+include/ctpp2/CTPP2ParserException.hpp
+include/ctpp2/CTPP2SimpleCompiler.hpp
+include/ctpp2/CTPP2SimpleVM.hpp
+include/ctpp2/CTPP2SourceLoader.hpp
+include/ctpp2/CTPP2Sprintf.hpp
+include/ctpp2/CTPP2StaticData.hpp
+include/ctpp2/CTPP2StaticText.hpp
+include/ctpp2/CTPP2StreamOutputCollector.hpp
+include/ctpp2/CTPP2StringBuffer.hpp
+include/ctpp2/CTPP2StringIconvOutputCollector.hpp
+include/ctpp2/CTPP2StringOutputCollector.hpp
+include/ctpp2/CTPP2SymbolTable.hpp
+include/ctpp2/CTPP2Syntax.h
+include/ctpp2/CTPP2SysHeaders.h
+include/ctpp2/CTPP2SysTypes.h
+include/ctpp2/CTPP2SyscallFactory.hpp
+include/ctpp2/CTPP2Types.h
+include/ctpp2/CTPP2Util.hpp
+include/ctpp2/CTPP2VM.hpp
+include/ctpp2/CTPP2VMArgStack.hpp
+include/ctpp2/CTPP2VMCodeStack.hpp
+include/ctpp2/CTPP2VMDebugInfo.hpp
+include/ctpp2/CTPP2VMDumper.hpp
+include/ctpp2/CTPP2VMException.hpp
+include/ctpp2/CTPP2VMExecutable.hpp
+include/ctpp2/CTPP2VMFileLoader.hpp
+include/ctpp2/CTPP2VMInstruction.hpp
+include/ctpp2/CTPP2VMLoader.hpp
+include/ctpp2/CTPP2VMMemoryCore.hpp
+include/ctpp2/CTPP2VMOpcodeCollector.hpp
+include/ctpp2/CTPP2VMOpcodes.h
+include/ctpp2/CTPP2VMSTDLib.hpp
+include/ctpp2/CTPP2VMStackException.hpp
+include/ctpp2/CTPP2VMSyscall.hpp
+include/ctpp2/STLException.hpp
+include/ctpp2/STLFunctional.hpp
+include/ctpp2/STLIosfwd.hpp
+include/ctpp2/STLMap.hpp
+include/ctpp2/STLOstream.hpp
+include/ctpp2/STLPair.hpp
+include/ctpp2/STLString.hpp
+include/ctpp2/STLVector.hpp
+lib/libctpp2-st.a
+lib/libctpp2.so
+lib/libctpp2.so.2
+lib/libctpp2.so.%%PORTVERSION%%
+@dirrm include/ctpp2