summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2017-07-23 10:09:07 +0200
committerDidier Raboud <odyx@debian.org>2017-07-23 10:09:07 +0200
commit0f983307b0dcfbc041c8f5f95f58d5fdcdd6c307 (patch)
tree66996e1a8b1ad790b09c0890ac7986873b7d435a /Makefile.am
Import cups-bjnp_2.0.orig.tar.gz
[dgit import orig cups-bjnp_2.0.orig.tar.gz]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..19fa7f0
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,27 @@
+## Process this file with automake to produce Makefile.in
+# We must define a dummy directory for the backenddir so make discheck works
+AM_DISTCHECK_CONFIGURE_FLAGS = --with-cupsbackenddir=/tmp
+
+cupsbackend_PROGRAMS = bjnp
+bjnp_SOURCES = \
+ bjnp.c \
+ bjnp-runloop.c \
+ bjnp-io.c \
+ bjnp-debug.c \
+ bjnp-utils.c \
+ bjnp-discover.c \
+ bjnp-commands.c \
+ bjnp-levels.c \
+ cups-bjnp.spec \
+ bjnp.h \
+ bjnp-commands.h \
+ bjnp-protocol.h \
+ bjnp-io.h \
+ TODO \
+ README \
+ README.levels \
+ COPYING
+bjnp_CFLAGS = -Wall $(CUPS_CFLAGS) $(EXTRA_CFLAGS)
+bjnp_LDFLAGS = $(CUPS_LDFLAGS)
+bjnp_LDADD = $(CUPS_LIBS)
+