summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Kamppeter <till.kamppeter@gmail.com>2012-11-29 12:20:48 +0100
committerDidier Raboud <odyx@debian.org>2013-12-05 17:13:06 +0100
commit58a76c248dffa73fca59836a2e1688c6bf9d30e5 (patch)
treeac030c0e41a1d81a8213e99562c83805e73bfe09
parent46b6165bbf62bf75d6afe97c558f20a1b783b095 (diff)
* New upstream release
- urftopdf: Newly added filter to convert the URF format which (at least some) iOS apps send when printing via AirPrint (Upstream bug #1076). - pdftopdf: pdfautorotate functionality has been patched directly into pdftopdf (LP: #1040037, Upstream bug #1080). - pdftopdf: "mirror" produced only empty pages (XObjects not there). - pdftopdf: Fixed segfault on "page-ranges=1-2147483647" (from cups). - pdftopdf: Fixed collate filler insertion. - texttopdf: Fixed deficient string escaping (Upstream bug #1071). - serial backend: Added check for sys/ioctl.h to configure.ac (Upstream bug #1069). * debian/patches/texttopdf-fix-deficient-string-escaping.patch: Removed fix backported from upstream. * debian/rules: Added "DEB_DH_FIXPERMS_ARGS := -Xusr/lib/cups/backend" to not correct the permissions of CUPS backends (LP: #1076786).
-rw-r--r--debian/changelog21
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/texttopdf-fix-deficient-string-escaping.patch29
-rwxr-xr-xdebian/rules3
4 files changed, 23 insertions, 31 deletions
diff --git a/debian/changelog b/debian/changelog
index e45dc6d5c..4e5b92ed0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,24 @@
+cups-filters (1.0.25-0ubuntu1) raring; urgency=low
+
+ * New upstream release
+ - urftopdf: Newly added filter to convert the URF format which (at
+ least some) iOS apps send when printing via AirPrint (Upstream bug
+ #1076).
+ - pdftopdf: pdfautorotate functionality has been patched directly
+ into pdftopdf (LP: #1040037, Upstream bug #1080).
+ - pdftopdf: "mirror" produced only empty pages (XObjects not there).
+ - pdftopdf: Fixed segfault on "page-ranges=1-2147483647" (from cups).
+ - pdftopdf: Fixed collate filler insertion.
+ - texttopdf: Fixed deficient string escaping (Upstream bug #1071).
+ - serial backend: Added check for sys/ioctl.h to configure.ac (Upstream bug
+ #1069).
+ * debian/patches/texttopdf-fix-deficient-string-escaping.patch: Removed
+ fix backported from upstream.
+ * debian/rules: Added "DEB_DH_FIXPERMS_ARGS := -Xusr/lib/cups/backend" to not
+ correct the permissions of CUPS backends (LP: #1076786).
+
+ -- Till Kamppeter <till.kamppeter@gmail.com> Wed, 28 Nov 2012 20:14:07 +0100
+
cups-filters (1.0.24-3) experimental; urgency=low
* Add bc to cups-filters' depends as pstopdf uses it.
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 5c8b8da7c..000000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-texttopdf-fix-deficient-string-escaping.patch
diff --git a/debian/patches/texttopdf-fix-deficient-string-escaping.patch b/debian/patches/texttopdf-fix-deficient-string-escaping.patch
deleted file mode 100644
index 786560dc5..000000000
--- a/debian/patches/texttopdf-fix-deficient-string-escaping.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/filter/pdfutils.c
-+++ b/filter/pdfutils.c
-@@ -37,7 +37,7 @@
- len=strlen(str);
- }
- putc('(',stdout);
-- // escape special chars: \0 \\ \)
-+ // escape special chars: \0 \\ \( \) -- don't bother about balanced parens
- int iA=0;
- for (;len>0;iA++,len--) {
- if ( (str[iA]<32)||(str[iA]>126) ) {
-@@ -46,7 +46,7 @@
- pdf->filepos+=iA+4;
- str+=iA+1;
- iA=-1;
-- } else if ( (str[iA]==')')||(str[iA]=='\\') ) {
-+ } else if ( (str[iA]=='(')||(str[iA]==')')||(str[iA]=='\\') ) {
- fwrite(str,1,iA,stdout);
- fprintf(stdout,"\\%c",str[iA]);
- pdf->filepos+=iA+2;
-@@ -287,7 +287,7 @@
- pdfOut *pdf=(pdfOut *)context;
-
- if (fwrite(buf,1,len,stdout)!=len) {
-- fprintf(stderr,"Short write: %m\n");
-+ perror("Short write");
- assert(0);
- return;
- }
diff --git a/debian/rules b/debian/rules
index 3fde452e9..58f053f38 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,7 @@ DEB_INSTALL_CHANGELOGS_ALL := NEWS
#DEB_DH_STRIP_ARGS := --dbg-package=cups-filters-dbg
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
+DEB_DH_FIXPERMS_ARGS := -Xusr/lib/cups/backend
DPKG_GENSYMBOLS_CHECK_LEVEL=4
export DPKG_GENSYMBOLS_CHECK_LEVEL
@@ -40,4 +41,4 @@ binary-post-install/cups-filters::
# Make the serial backend run as root, since /dev/ttyS* are
# root:dialout and thus not accessible as user lp
- chmod go-x debian/$(cdbs_curpkg)/usr/lib/cups/backend/serial
+ chmod 700 debian/$(cdbs_curpkg)/usr/lib/cups/backend/serial