summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTill Kamppeter <till.kamppeter@gmail.com>2012-12-28 18:29:38 +0100
committerDidier Raboud <odyx@debian.org>2013-12-05 17:15:07 +0100
commit983af75381b925a78fc8215029b7e0ea6dc4d5ab (patch)
tree953d609806b519437c155bd668198add50fa5c33 /debian/rules
parente3a0681f69cce5e52f5890e0a1f50cfa42a5b4c5 (diff)
* New upstream release
- cups-browsed: Added daemon to browse the Bonjour broadcasts of shared remote CUPS printers and automatically add local raw queues pointing to them, to resemble the behavior of the former CUPS broadcasting/browsing which was dropped in CUPS 1.6. Now remote printers appear as local print queues as before, but with the standardized Bonjour broadcasting (LP: #1086019, LP: #1061063, LP: #1061069). * debian/control: Added build dependencies on Avahi, needed for the new cups-browsed and also a new binary package named cups-browsed. * debian/cups-browsed.install: New cups-browsed binary package. * debian/local/cups-browsed.upstart: Upstart configuration file for cups-browsed. * debian/rules: Added everything needed so that the cups-browsed daemon gets started automatically. * debian/cups-filters.install: Include files from /usr/bin.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 18 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 58f053f38..6a193db89 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,9 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
DEB_CONFIGURE_EXTRA_FLAGS := --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) --mandir=/usr/share/man --enable-static
+# Do not install /etc/rc?.d/* links, on Ubuntu we use Upstart and on Debian
+# we create the links on our own
+# DEB_CONFIGURE_EXTRA_FLAGS += --with-rcdir=/etc/init.d --with-rclevels=
DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(DEB_DESTDIR)
DEB_INSTALL_CHANGELOGS_ALL := NEWS
@@ -27,8 +30,22 @@ DEB_DH_FIXPERMS_ARGS := -Xusr/lib/cups/backend
DPKG_GENSYMBOLS_CHECK_LEVEL=4
export DPKG_GENSYMBOLS_CHECK_LEVEL
+ifeq ($(shell dpkg-vendor --query vendor), Ubuntu)
+DEB_DH_INSTALLINIT_ARGS := --upstart-only
+else
+DEB_DH_INSTALLINIT_ARGS := -u'start 50 2 3 4 5 . stop 80 1 .'
+endif
+
cleanbuilddir::
- [ ! -f Makedefs ] || make distclean
+ [ ! -r Makefile ] || make distclean
+ rm -f debian/*.upstart # master copy is in debian/local
+
+common-install-prehook-impl::
+ # Use upstart script on Ubuntu; we need to hide it away for Debian
+ # builds, as dh_installinit does not have a --sysvinit-only
+ if dpkg-vendor --is ubuntu; then \
+ cp debian/local/*.upstart debian; \
+ fi
binary-post-install/cups-filters::
# Ubuntu-specific stuff