summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--INSTALL2
-rw-r--r--NEWS10
-rw-r--r--README2
-rwxr-xr-xconfigure20
-rw-r--r--configure.ac2
-rw-r--r--utils/cups-browsed.c9
6 files changed, 31 insertions, 14 deletions
diff --git a/INSTALL b/INSTALL
index da2661977..0a55ac851 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,4 +1,4 @@
-INSTALL - OpenPrinting CUPS Filters v1.17.8 - 2017-09-28
+INSTALL - OpenPrinting CUPS Filters v1.17.9 - 2017-10-05
--------------------------------------------------------
This file describes how to compile and install OpenPrinting CUPS
diff --git a/NEWS b/NEWS
index 75779a1e3..e3824f434 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,14 @@
-NEWS - OpenPrinting CUPS Filters v1.17.8 - 2017-09-28
+NEWS - OpenPrinting CUPS Filters v1.17.9 - 2017-10-05
-----------------------------------------------------
+CHANGES IN V1.17.9
+
+ - cups-browsed: Applying option defaults from the
+ DefaultOptions directive in cups-browsed.conf got
+ lost. Re-introduced it (Bug #1414).
+ - cups-browsed: Get printer-location field from remote
+ printers. Thanks to Marek Kasik for the patch (Bug #1413).
+
CHANGES IN V1.17.8
- foomatic-rip: Change execution of renderer thread to fail
diff --git a/README b/README
index 082479ff7..25cb9f4dd 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-README - OpenPrinting CUPS Filters v1.17.8 - 2017-09-28
+README - OpenPrinting CUPS Filters v1.17.9 - 2017-10-05
-------------------------------------------------------
Looking for compile instructions? Read the file "INSTALL.txt"
diff --git a/configure b/configure
index 69a03b93f..e2bdd21fb 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for cups-filters 1.17.8.
+# Generated by GNU Autoconf 2.69 for cups-filters 1.17.9.
#
#
# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -587,8 +587,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='cups-filters'
PACKAGE_TARNAME='cups-filters'
-PACKAGE_VERSION='1.17.8'
-PACKAGE_STRING='cups-filters 1.17.8'
+PACKAGE_VERSION='1.17.9'
+PACKAGE_STRING='cups-filters 1.17.9'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@@ -1497,7 +1497,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures cups-filters 1.17.8 to adapt to many kinds of systems.
+\`configure' configures cups-filters 1.17.9 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1568,7 +1568,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of cups-filters 1.17.8:";;
+ short | recursive ) echo "Configuration of cups-filters 1.17.9:";;
esac
cat <<\_ACEOF
@@ -1797,7 +1797,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-cups-filters configure 1.17.8
+cups-filters configure 1.17.9
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2435,7 +2435,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by cups-filters $as_me 1.17.8, which was
+It was created by cups-filters $as_me 1.17.9, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -3470,7 +3470,7 @@ fi
# Define the identity of the package.
PACKAGE='cups-filters'
- VERSION='1.17.8'
+ VERSION='1.17.9'
cat >>confdefs.h <<_ACEOF
@@ -21784,7 +21784,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by cups-filters $as_me 1.17.8, which was
+This file was extended by cups-filters $as_me 1.17.9, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -21850,7 +21850,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-cups-filters config.status 1.17.8
+cups-filters config.status 1.17.9
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index df7fed582..520325a4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,7 +7,7 @@ AC_PREREQ([2.65])
# ====================
m4_define([cups_filters_version_major],[1])
m4_define([cups_filters_version_minor],[17])
-m4_define([cups_filters_version_micro],[8])
+m4_define([cups_filters_version_micro],[9])
m4_define([cups_filters_version],[cups_filters_version_major.cups_filters_version_minor.cups_filters_version_micro])
# =============
diff --git a/utils/cups-browsed.c b/utils/cups-browsed.c
index cf9b063ae..d803fca5f 100644
--- a/utils/cups-browsed.c
+++ b/utils/cups-browsed.c
@@ -4357,6 +4357,14 @@ gboolean update_cups_queues(gpointer unused) {
debug_printf("Creating permanent CUPS queue %s.\n",
p->queue_name);
+ /* Do we have default option settings in cups-browsed.conf? */
+ if (DefaultOptions) {
+ debug_printf("Applying default option settings to printer %s: %s\n",
+ p->queue_name, DefaultOptions);
+ p->num_options = cupsParseOptions(DefaultOptions, p->num_options,
+ &p->options);
+ }
+
/* Loading saved option settings from last session */
p->num_options = load_printer_options(p->queue_name, p->num_options,
&p->options);
@@ -6490,6 +6498,7 @@ static void
browse_poll_get_printers (browsepoll_t *context, http_t *conn)
{
static const char * const rattrs[] = { "printer-uri-supported",
+ "printer-location",
"printer-info"};
ipp_t *request, *response = NULL;
ipp_attribute_t *attr;