summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-01-29 16:52:03 +0000
committerjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-01-29 16:52:03 +0000
commita4d045870e17abe8840b77615c0d59f4b332ee31 (patch)
tree156a1bf6d89ea7d14d78d947a205f7317f4e0a9d /Makefile
parent09ec001812911f8890dad0f164ab9098e22208cf (diff)
Load cups into easysw/current.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@39 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 9cfaec9bb..99a042d5b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile 5003 2006-01-27 02:33:36Z mike $"
+# "$Id: Makefile 5023 2006-01-29 14:39:44Z mike $"
#
# Top-level Makefile for the Common UNIX Printing System (CUPS).
#
@@ -29,7 +29,7 @@ include Makedefs
#
DIRS = cups backend berkeley cgi-bin filter locale man pdftops \
- notifier scheduler systemv
+ notifier scheduler systemv test
#
# Make all targets...
@@ -107,6 +107,12 @@ install: installhdrs
$(INSTALL_DATA) init/cups.plist $(BUILDROOT)$(INITDDIR)/StartupParameters.plist; \
$(INSTALL_DIR) $(BUILDROOT)$(INITDDIR)/Resources/English.lproj; \
$(INSTALL_DATA) init/cups.strings $(BUILDROOT)$(INITDDIR)/Resources/English.lproj/Localizable.strings; \
+ elif test "$(INITDDIR)" = "/System/Library/LaunchDaemons"; then \
+ $(INSTALL_DATA) init/cupsd-launchd.plist $(BUILDROOT)$(DEFAULT_LAUNCHD_CONF); \
+ $(INSTALL_SCRIPT) init/cupsd-launchd.sh $(BUILDROOT)/System/Library/StartupItems/PrintingServices/PrintingServices; \
+ $(INSTALL_DATA) init/cups.plist $(BUILDROOT)/System/Library/StartupItems/PrintingServices/StartupParameters.plist; \
+ $(INSTALL_DIR) $(BUILDROOT)/System/Library/StartupItems/PrintingServices/Resources/English.lproj; \
+ $(INSTALL_DATA) init/cups.strings $(BUILDROOT)/System/Library/StartupItems/PrintingServices/Resources/English.lproj/Localizable.strings; \
else \
$(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDDIR)/cups; \
fi \
@@ -165,5 +171,5 @@ tardist:
epm $(EPMFLAGS) -f tardist cups packaging/cups.list
#
-# End of "$Id: Makefile 5003 2006-01-27 02:33:36Z mike $".
+# End of "$Id: Makefile 5023 2006-01-29 14:39:44Z mike $".
#