summaryrefslogtreecommitdiff
path: root/backend
diff options
context:
space:
mode:
authorMichael Sweet <michael.r.sweet@gmail.com>2016-05-02 13:03:47 -0400
committerMichael Sweet <michael.r.sweet@gmail.com>2016-05-02 13:03:47 -0400
commit6fb588e01a8b77bf34b015cba8337427310dd16c (patch)
tree14bedbdacf40323173f97dbcef09c30528ab0ece /backend
parentd928965bc2fe48a603686c7d1d5c97fb75f0f4e9 (diff)
Stagger connect calls by 100ms to avoid "confusing" printers and/or the network
stack. Add a socket-static target for testing.
Diffstat (limited to 'backend')
-rw-r--r--backend/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/backend/Makefile b/backend/Makefile
index a4017bf77..ae08947fb 100644
--- a/backend/Makefile
+++ b/backend/Makefile
@@ -1,7 +1,7 @@
#
# Backend makefile for CUPS.
#
-# Copyright 2007-2014 by Apple Inc.
+# Copyright 2007-2016 by Apple Inc.
# Copyright 1997-2007 by Easy Software Products, all rights reserved.
#
# These coded instructions, statements, and computer programs are the
@@ -86,7 +86,7 @@ unittests: $(UNITTESTS)
#
clean:
- $(RM) $(OBJS) $(TARGETS) $(UNITTESTS) $(LIBOBJS) http https ipps mdns
+ $(RM) $(OBJS) $(TARGETS) $(UNITTESTS) $(LIBOBJS) http https ipps mdns socket-static
#
@@ -293,6 +293,12 @@ socket: socket.o ../cups/$(LIBCUPS) libbackend.a
echo Linking $@...
$(CC) $(LDFLAGS) -o socket socket.o libbackend.a $(LIBS)
+socket-static: socket.o ../cups/$(LIBCUPSSTATIC) libbackend.a
+ echo Linking $@...
+ $(CC) $(LDFLAGS) -o socket-static socket.o libbackend.a \
+ ../cups/$(LIBCUPSSTATIC) $(LIBGSSAPI) $(SSLLIBS) $(DNSSDLIBS) \
+ $(COMMONLIBS) $(LIBZ)
+
#
# usb