summaryrefslogtreecommitdiff
path: root/backend
diff options
context:
space:
mode:
authorMartin Pitt <mpitt@debian.org>2016-08-09 18:11:06 +0200
committerDidier Raboud <odyx@debian.org>2018-06-08 15:05:57 +0200
commitcbf4960342e5343ae7f67be7827c8870d9c12032 (patch)
treef30ba64d54b7c9e598a3eb0d32b7031d6bb63324 /backend
parent563b8a1b7fedf0a61928f16188823ba6f355044f (diff)
Install root backends world-readable
This is needed: - to comply with Debian Policy - because it is both nonsensical to not do so - it also breaks system checkers, bug reporting, etc Bug: http://www.cups.org/str.php?L2935 Bug-Debian: http://bugs.debian.org/410171 Last-Update: 2015-02-10 Patch-Name: rootbackends-worldreadable.patch
Diffstat (limited to 'backend')
-rw-r--r--backend/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/backend/Makefile b/backend/Makefile
index 95e07b27e..72d7a105e 100644
--- a/backend/Makefile
+++ b/backend/Makefile
@@ -13,7 +13,7 @@ include ../Makedefs
# Object files...
#
-# RBACKENDS are installed mode 0700 so cupsd will run them as root...
+# RBACKENDS are installed mode 0744 so cupsd will run them as root...
#
# UBACKENDS and ULBACKENDS are installed mode 0755 so cupsd will run them as
# an unprivileged user...
@@ -118,7 +118,7 @@ install-exec: $(INSTALLXPC)
echo Installing backends in $(SERVERBIN)/backend
$(INSTALL_DIR) -m 755 $(SERVERBIN)/backend
for file in $(RBACKENDS); do \
- $(LIBTOOL) $(INSTALL_BIN) -m 700 $$file $(SERVERBIN)/backend; \
+ $(LIBTOOL) $(INSTALL_BIN) -m 744 $$file $(SERVERBIN)/backend; \
done
for file in $(UBACKENDS); do \
$(INSTALL_BIN) $$file $(SERVERBIN)/backend; \