summaryrefslogtreecommitdiff
path: root/conf/Makefile
diff options
context:
space:
mode:
authorjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-01-26 21:39:43 +0000
committerjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-01-26 21:39:43 +0000
commitfa73b22906f71080fa5056485d8204612717adac (patch)
treef2f23b68c20d1fc9a85301527690aca5efa382df /conf/Makefile
parent4a09f02d10d679af0b04d36c25f0dcb518e432a4 (diff)
Load cups into easysw/current.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@13 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'conf/Makefile')
-rw-r--r--conf/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/conf/Makefile b/conf/Makefile
index fe060d9c9..684693806 100644
--- a/conf/Makefile
+++ b/conf/Makefile
@@ -1,9 +1,9 @@
#
-# "$Id: Makefile 4664 2005-09-17 22:56:56Z mike $"
+# "$Id: Makefile 4972 2006-01-24 14:48:12Z mike $"
#
# Configuration file makefile for the Common UNIX Printing System (CUPS).
#
-# Copyright 1993-2005 by Easy Software Products.
+# Copyright 1993-2006 by Easy Software Products.
#
# These coded instructions, statements, and computer programs are the
# property of Easy Software Products and are protected by Federal
@@ -28,7 +28,7 @@ include ../Makedefs
# Config files...
#
-KEEP = classes.conf client.conf cupsd.conf printers.conf
+KEEP = client.conf cupsd.conf
REPLACE = mime.convs mime.types
@@ -50,7 +50,7 @@ clean:
# Install files...
#
-install:
+install: all
$(INSTALL_DIR) $(SERVERROOT)
for file in $(KEEP); do \
if test -r $(SERVERROOT)/$$file ; then \
@@ -59,6 +59,7 @@ install:
$(INSTALL_DATA) $$file $(SERVERROOT) ; \
fi ; \
done
+ $(INSTALL_DATA) cupsd.conf $(SERVERROOT)/cupsd.conf.default
for file in $(REPLACE); do \
if test -r $(SERVERROOT)/$$file ; then \
$(MV) $(SERVERROOT)/$$file $(SERVERROOT)/$$file.O ; \
@@ -76,5 +77,5 @@ install:
#
-# End of "$Id: Makefile 4664 2005-09-17 22:56:56Z mike $".
+# End of "$Id: Makefile 4972 2006-01-24 14:48:12Z mike $".
#