summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authorjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-02-20 18:43:55 +0000
committerjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-02-20 18:43:55 +0000
commitbd7854cb4d663bb0e561eaf5b01bbd47baa71d22 (patch)
treebca042d698732a5e19035c88c6ffc39d80f543f1 /conf
parent4400e98de24bd267328aa20d57951fb6678297fe (diff)
Load cups into easysw/current.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@60 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'conf')
-rw-r--r--conf/Makefile12
-rw-r--r--conf/cupsd.conf.in6
2 files changed, 11 insertions, 7 deletions
diff --git a/conf/Makefile b/conf/Makefile
index cf2f88a8a..6949cb3db 100644
--- a/conf/Makefile
+++ b/conf/Makefile
@@ -1,5 +1,5 @@
#
-# "$Id: Makefile 5008 2006-01-27 19:30:34Z mike $"
+# "$Id: Makefile 5126 2006-02-17 16:11:30Z mike $"
#
# Configuration file makefile for the Common UNIX Printing System (CUPS).
#
@@ -51,23 +51,27 @@ clean:
#
install: all
- $(INSTALL_DIR) $(SERVERROOT)
+ $(INSTALL_DIR) -m 755 $(SERVERROOT)
for file in $(KEEP); do \
if test -r $(SERVERROOT)/$$file ; then \
$(INSTALL_CONFIG) $$file $(SERVERROOT)/$$file.N ; \
+ chgrp $(CUPS_GROUP) $(SERVERROOT)/$$file.N || true; \
else \
$(INSTALL_CONFIG) $$file $(SERVERROOT) ; \
+ chgrp $(CUPS_GROUP) $(SERVERROOT)/$$file || true; \
fi ; \
done
$(INSTALL_CONFIG) cupsd.conf $(SERVERROOT)/cupsd.conf.default
+ -chgrp $(CUPS_GROUP) $(SERVERROOT)/cupsd.conf.default
for file in $(REPLACE); do \
if test -r $(SERVERROOT)/$$file ; then \
$(MV) $(SERVERROOT)/$$file $(SERVERROOT)/$$file.O ; \
fi ; \
$(INSTALL_CONFIG) $$file $(SERVERROOT) ; \
+ chgrp $(CUPS_GROUP) $(SERVERROOT)/$$file || true; \
done
-if test x$(PAMDIR) != x$(BUILDROOT); then \
- $(INSTALL_DIR) $(PAMDIR); \
+ $(INSTALL_DIR) -m 755 $(PAMDIR); \
if test -r $(PAMDIR)/cups/$(PAMFILE) ; then \
$(INSTALL_DATA) $(PAMFILE) $(PAMDIR)/cups.N ; \
else \
@@ -77,5 +81,5 @@ install: all
#
-# End of "$Id: Makefile 5008 2006-01-27 19:30:34Z mike $".
+# End of "$Id: Makefile 5126 2006-02-17 16:11:30Z mike $".
#
diff --git a/conf/cupsd.conf.in b/conf/cupsd.conf.in
index e3b73ea7a..426077b1b 100644
--- a/conf/cupsd.conf.in
+++ b/conf/cupsd.conf.in
@@ -1,5 +1,5 @@
#
-# "$Id: cupsd.conf.in 4817 2005-11-04 16:21:01Z mike $"
+# "$Id: cupsd.conf.in 5114 2006-02-16 12:28:29Z mike $"
#
# Sample configuration file for the Common UNIX Printing System (CUPS)
# scheduler. See "man cupsd.conf" for a complete description of this
@@ -11,7 +11,7 @@
LogLevel info
# Administrator user group...
-SystemGroup @CUPS_GROUP@
+SystemGroup @CUPS_SYSTEM_GROUPS@
# Only listen for connections from the local machine.
Listen localhost:@DEFAULT_IPP_PORT@
@@ -72,5 +72,5 @@ DefaultAuthType Basic
</Policy>
#
-# End of "$Id: cupsd.conf.in 4817 2005-11-04 16:21:01Z mike $".
+# End of "$Id: cupsd.conf.in 5114 2006-02-16 12:28:29Z mike $".
#