summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-06-18 16:44:53 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2008-06-18 16:44:53 +0000
commitdd1abb6b5f145c5e5f279d8848b5f3ec161fd227 (patch)
tree48d46ed8d33890c2b5d047996f5a61aab8990520 /conf
parentc934a06cde0e8f2657b7e614df31fd300658d53e (diff)
Merge changes from CUPS 1.4svn-r7670.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@810 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'conf')
-rw-r--r--conf/Makefile12
-rw-r--r--conf/cupsd.conf.in4
-rw-r--r--conf/mime.types4
3 files changed, 15 insertions, 5 deletions
diff --git a/conf/Makefile b/conf/Makefile
index 90ab0cd54..4bb31c9ed 100644
--- a/conf/Makefile
+++ b/conf/Makefile
@@ -75,11 +75,15 @@ install-data:
done
$(INSTALL_CONFIG) cupsd.conf $(SERVERROOT)/cupsd.conf.default
-chgrp $(CUPS_GROUP) $(SERVERROOT)/cupsd.conf.default
+ $(INSTALL_DIR) -m 755 $(DATADIR)/mime
for file in $(REPLACE); do \
+ if test -r $(DATADIR)/mime/$$file ; then \
+ $(MV) $(DATADIR)/mime/$$file $(DATADIR)/mime/$$file.O ; \
+ fi ; \
if test -r $(SERVERROOT)/$$file ; then \
- $(MV) $(SERVERROOT)/$$file $(SERVERROOT)/$$file.O ; \
+ $(MV) $(SERVERROOT)/$$file $(DATADIR)/mime/$$file.O ; \
fi ; \
- $(INSTALL_DATA) $$file $(SERVERROOT) ; \
+ $(INSTALL_DATA) $$file $(DATADIR)/mime ; \
done
-if test x$(PAMDIR) != x; then \
$(INSTALL_DIR) -m 755 $(BUILDROOT)$(PAMDIR); \
@@ -121,6 +125,10 @@ uninstall:
$(RM) $(SERVERROOT)/$$file; \
done
-$(RMDIR) $(SERVERROOT)
+ for file in $(REPLACE); do \
+ $(RM) $(DATADIR)/mime/$$file; \
+ done
+ -$(RMDIR) $(DATADIR)/mime
-if test x$(PAMDIR) != x; then \
$(RM) $(BUILDROOT)$(PAMDIR)/cups; \
$(RMDIR) $(BUILDROOT)$(PAMDIR); \
diff --git a/conf/cupsd.conf.in b/conf/cupsd.conf.in
index 3561a805e..8939b8a4b 100644
--- a/conf/cupsd.conf.in
+++ b/conf/cupsd.conf.in
@@ -48,7 +48,7 @@ DefaultAuthType Basic
# Set the default printer/job policies...
<Policy default>
# Job-related operations must be done by the owner or an administrator...
- <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
+ <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job CUPS-Get-Document>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>
@@ -81,7 +81,7 @@ DefaultAuthType Basic
# Set the authenticated printer/job policies...
<Policy authenticated>
# Job-related operations must be done by the owner or an administrator...
- <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
+ <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job CUPS-Get-Document>
Require user @OWNER @SYSTEM
Order deny,allow
AuthType Default
diff --git a/conf/mime.types b/conf/mime.types
index bda116265..1852d460c 100644
--- a/conf/mime.types
+++ b/conf/mime.types
@@ -7,7 +7,7 @@
# VERSIONS OF CUPS. Instead, create a "local.types" file that
# reflects your local configuration changes.
#
-# Copyright 2007 by Apple Inc.
+# Copyright 2007-2008 by Apple Inc.
# Copyright 1997-2007 by Easy Software Products.
#
# These coded instructions, statements, and computer programs are the
@@ -33,6 +33,8 @@
# extension Pattern match on "*.extension"
# ascii(offset,length) True if bytes are valid printable ASCII
# (CR, NL, TAB, BS, 32-126)
+# priority(number) Sets priority of type (0=lowest,
+# 100=default, 200=highest)
# printable(offset,length) True if bytes are printable 8-bit chars
# (CR, NL, TAB, BS, 32-126, 128-254)
# string(offset,"string") True if bytes are identical to string