summaryrefslogtreecommitdiff
path: root/notifier/Makefile
diff options
context:
space:
mode:
authorjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-01-13 01:51:53 +0000
committerjlovell <jlovell@a1ca3aef-8c08-0410-bb20-df032aa958be>2006-01-13 01:51:53 +0000
commitef416fc25c4af449e930416117bedb12fc9924ba (patch)
tree11f8aa8c5d3565a17d4a6d5121d3edba22e2a21e /notifier/Makefile
parent9ec11526e139aeacf6a052799a6aa22cbbe6ebb2 (diff)
Load cups into easysw/current.
git-svn-id: svn+ssh://src.apple.com/svn/cups/easysw/current@2 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'notifier/Makefile')
-rw-r--r--notifier/Makefile91
1 files changed, 91 insertions, 0 deletions
diff --git a/notifier/Makefile b/notifier/Makefile
new file mode 100644
index 000000000..f7c139f44
--- /dev/null
+++ b/notifier/Makefile
@@ -0,0 +1,91 @@
+#
+# "$Id: Makefile 4834 2005-11-12 21:55:57Z mike $"
+#
+# Notifier makefile for the Common UNIX Printing System (CUPS).
+#
+# Copyright 1997-2005 by Easy Software Products, all rights reserved.
+#
+# These coded instructions, statements, and computer programs are the
+# property of Easy Software Products and are protected by Federal
+# copyright law. Distribution and use rights are outlined in the file
+# "LICENSE.txt" which should have been included with this file. If this
+# file is missing or damaged please contact Easy Software Products
+# at:
+#
+# Attn: CUPS Licensing Information
+# Easy Software Products
+# 44141 Airport View Drive, Suite 204
+# Hollywood, Maryland 20636 USA
+#
+# Voice: (301) 373-9600
+# EMail: cups-info@cups.org
+# WWW: http://www.cups.org
+#
+
+include ../Makedefs
+
+
+TARGETS = mailto testnotify
+OBJS = mailto.o testnotify.o
+
+
+#
+# Make all targets...
+#
+
+all: $(TARGETS)
+
+
+#
+# Clean all object files...
+#
+
+clean:
+ $(RM) $(OBJS) $(TARGETS)
+
+
+#
+# Install all targets...
+#
+
+install:
+ $(INSTALL_DIR) $(SERVERBIN)/notifier
+ for file in $(TARGETS); do \
+ $(INSTALL_BIN) $$file $(SERVERBIN)/notifier; \
+ done
+
+
+#
+# Update dependencies (without system header dependencies...)
+#
+
+depend:
+ makedepend -Y -I.. -fDependencies $(OBJS:.o=.c) >/dev/null 2>&1
+
+
+#
+# mailto
+#
+
+mailto: mailto.o ../cups/$(LIBCUPS)
+ echo Linking $@...
+ $(CC) $(LDFLAGS) -o mailto mailto.o $(LIBS)
+
+
+#
+# testnotify
+#
+
+testnotify: testnotify.o ../cups/$(LIBCUPS)
+ echo Linking $@...
+ $(CC) $(LDFLAGS) -o testnotify testnotify.o $(LIBS)
+
+
+$(OBJS): ../Makedefs
+
+include Dependencies
+
+
+#
+# End of "$Id: Makefile 4834 2005-11-12 21:55:57Z mike $".
+#