summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/conf/Makefile b/conf/Makefile
index 42a123f75..db0060d75 100644
--- a/conf/Makefile
+++ b/conf/Makefile
@@ -69,8 +69,12 @@ install-data:
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT)/$$file.N ; \
else \
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(SERVERROOT) ; \
+ grep -v "\$$Id[:\$$]" $(SERVERROOT)/$$file > $(SERVERROOT)/$$file.n ; \
+ mv $(SERVERROOT)/$$file.n $(SERVERROOT)/$$file ; \
fi ; \
$(INSTALL_CONFIG) -g $(CUPS_GROUP) $$file $(DATADIR)/$$file.default; \
+ grep -v "\$$Id[:\$$]" $(DATADIR)/$$file.default > $(DATADIR)/$$file.default.n ; \
+ mv $(DATADIR)/$$file.default.n $(DATADIR)/$$file.default ; \
done
$(INSTALL_DIR) -m 755 $(DATADIR)/mime
for file in $(REPLACE); do \