summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Ghedini <al3xbio@gmail.com>2012-03-22 20:15:42 +0100
committerAlessandro Ghedini <al3xbio@gmail.com>2012-03-22 20:15:42 +0100
commitc1521024d33ba639a8d66385e30355ebbdff4705 (patch)
treeb178b1e38d39136e8db9ef5c528981cf1d97ff8c /CMakeLists.txt
parent048114422c503da411ebc440ce68eaf92e2c5f19 (diff)
Imported Upstream version 7.25.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dabdbcae..88dd1ee6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,9 +148,9 @@ option(ENABLE_IPV6 "Define if you want to enable IPv6 support" OFF)
mark_as_advanced(ENABLE_IPV6)
if(WIN32)
- find_library(WSOCK32_LIBRARY wsock32)
- find_library(WS2_32_LIBRARY ws2_32)
- list_spaces_append_once(CMAKE_C_STANDARD_LIBRARIES ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}) # bufferoverflowu.lib
+ # Windows standard libraries are located in C:/Program Files/Microsoft SDKs/[...]
+ # They are already included in the default MSVC LIBPATH => no find_library is needed!
+ list_spaces_append_once(CMAKE_C_STANDARD_LIBRARIES wsock32.lib ws2_32.lib) # bufferoverflowu.lib
if(CURL_DISABLE_LDAP)
# Remove wldap32.lib from space-separated list
string(REPLACE " " ";" _LIST ${CMAKE_C_STANDARD_LIBRARIES})