summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlessandro Ghedini <alessandro@ghedini.me>2015-08-12 10:34:59 +0200
committerAlessandro Ghedini <alessandro@ghedini.me>2015-08-12 10:34:59 +0200
commit9456f51adb76b83ceb4b95c8481325de62b25ad2 (patch)
treee5cfc1f4bc28cd81e93a96f9707a0efb143d278a /configure.ac
parentdbada9f3efae6d9d47b24d0fc06b31d5c48e59a9 (diff)
Imported Upstream version 7.44.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 42 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index accb0388..683299d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,7 @@ CURL_CHECK_OPTION_WERROR
CURL_CHECK_OPTION_CURLDEBUG
CURL_CHECK_OPTION_SYMBOL_HIDING
CURL_CHECK_OPTION_ARES
+CURL_CHECK_OPTION_RT
XC_CHECK_PATH_SEPARATOR
@@ -1509,6 +1510,46 @@ if test "$curl_ssl_msg" = "$init_ssl_msg" && test X"$OPT_SSL" != Xno; then
if test X"$HAVECRYPTO" = X"yes"; then
+ AC_MSG_CHECKING([OpenSSL linking without -ldl])
+ saved_libs=$LIBS
+ AC_TRY_LINK(
+ [
+ #include <openssl/evp.h>
+ ],
+ [
+ SSLeay_add_all_algorithms();
+ ],
+ [
+ AC_MSG_RESULT(yes)
+ LIBS="$saved_libs"
+ ],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_CHECKING([OpenSSL linking with -ldl])
+ LIBS="-ldl $LIBS"
+ AC_TRY_LINK(
+ [
+ #include <openssl/evp.h>
+ ],
+ [
+ SSLeay_add_all_algorithms();
+ ],
+ [
+ AC_MSG_RESULT(yes)
+ LIBS="$saved_libs -ldl"
+ ],
+ [
+ AC_MSG_RESULT(no)
+ LIBS="$saved_libs"
+ ]
+ )
+
+ ]
+ )
+
+ fi
+
+ if test X"$HAVECRYPTO" = X"yes"; then
dnl This is only reasonable to do if crypto actually is there: check for
dnl SSL libs NOTE: it is important to do this AFTER the crypto lib
@@ -3217,7 +3258,7 @@ if test "x$want_thres" = xyes && test "x$want_ares" = xyes; then
[Options --enable-threaded-resolver and --enable-ares are mutually exclusive])
fi
-if test "$want_thres" = "yes"; then
+if test "$want_thres" = "yes" && test "$dontwant_rt" = "no"; then
AC_CHECK_HEADER(pthread.h,
[ AC_DEFINE(HAVE_PTHREAD_H, 1, [if you have <pthread.h>])
save_CFLAGS="$CFLAGS"