summaryrefslogtreecommitdiff
path: root/lib/Makefile.vc10
diff options
context:
space:
mode:
authorAlessandro Ghedini <alessandro@ghedini.me>2013-04-16 20:16:20 +0200
committerAlessandro Ghedini <alessandro@ghedini.me>2013-04-16 20:16:20 +0200
commit3dfa7069afa426cb869f690b03fe3a7e3ce453f4 (patch)
treef89b19a04ee8c8db67d970fc286113499bcef70e /lib/Makefile.vc10
parent579d668f74ce35a997c56f9fd831016ed103d4ac (diff)
Imported Upstream version 7.30.0
Diffstat (limited to 'lib/Makefile.vc10')
-rw-r--r--lib/Makefile.vc1020
1 files changed, 17 insertions, 3 deletions
diff --git a/lib/Makefile.vc10 b/lib/Makefile.vc10
index c767d960..789eb9cb 100644
--- a/lib/Makefile.vc10
+++ b/lib/Makefile.vc10
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1999 - 2012, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1999 - 2013, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -62,10 +62,10 @@
# Makefile.msvc.names provides libcurl file names
# ------------------------------------------------
-!INCLUDE ..\Makefile.msvc.names
+!INCLUDE ..\winbuild\Makefile.msvc.names
!IFNDEF OPENSSL_PATH
-OPENSSL_PATH = ../../openssl-0.9.8x
+OPENSSL_PATH = ../../openssl-0.9.8y
!ENDIF
!IFNDEF LIBSSH2_PATH
@@ -494,8 +494,10 @@ clean:
# A config was provided, so the library can be built.
#
X_OBJS= \
+ $(DIROBJ)\amigaos.obj \
$(DIROBJ)\asyn-ares.obj \
$(DIROBJ)\asyn-thread.obj \
+ $(DIROBJ)\axtls.obj \
$(DIROBJ)\base64.obj \
$(DIROBJ)\bundles.obj \
$(DIROBJ)\conncache.obj \
@@ -506,6 +508,7 @@ X_OBJS= \
$(DIROBJ)\curl_darwinssl.obj \
$(DIROBJ)\curl_fnmatch.obj \
$(DIROBJ)\curl_gethostname.obj \
+ $(DIROBJ)\curl_gssapi.obj \
$(DIROBJ)\curl_memrchr.obj \
$(DIROBJ)\curl_multibyte.obj \
$(DIROBJ)\curl_ntlm.obj \
@@ -518,6 +521,7 @@ X_OBJS= \
$(DIROBJ)\curl_schannel.obj \
$(DIROBJ)\curl_sspi.obj \
$(DIROBJ)\curl_threads.obj \
+ $(DIROBJ)\cyassl.obj \
$(DIROBJ)\dict.obj \
$(DIROBJ)\easy.obj \
$(DIROBJ)\escape.obj \
@@ -544,10 +548,13 @@ X_OBJS= \
$(DIROBJ)\http_negotiate.obj \
$(DIROBJ)\http_negotiate_sspi.obj \
$(DIROBJ)\http_proxy.obj \
+ $(DIROBJ)\idn_win32.obj \
$(DIROBJ)\if2ip.obj \
$(DIROBJ)\imap.obj \
$(DIROBJ)\inet_ntop.obj \
$(DIROBJ)\inet_pton.obj \
+ $(DIROBJ)\krb4.obj \
+ $(DIROBJ)\krb5.obj \
$(DIROBJ)\ldap.obj \
$(DIROBJ)\llist.obj \
$(DIROBJ)\md4.obj \
@@ -556,15 +563,21 @@ X_OBJS= \
$(DIROBJ)\mprintf.obj \
$(DIROBJ)\multi.obj \
$(DIROBJ)\netrc.obj \
+ $(DIROBJ)\non-ascii.obj \
$(DIROBJ)\nonblock.obj \
+ $(DIROBJ)\nss.obj \
$(DIROBJ)\openldap.obj \
$(DIROBJ)\parsedate.obj \
$(DIROBJ)\pingpong.obj \
+ $(DIROBJ)\pipeline.obj \
$(DIROBJ)\polarssl.obj \
+ $(DIROBJ)\polarssl_threadlock.obj \
$(DIROBJ)\pop3.obj \
$(DIROBJ)\progress.obj \
+ $(DIROBJ)\qssl.obj \
$(DIROBJ)\rawstr.obj \
$(DIROBJ)\rtsp.obj \
+ $(DIROBJ)\security.obj \
$(DIROBJ)\select.obj \
$(DIROBJ)\sendf.obj \
$(DIROBJ)\share.obj \
@@ -578,6 +591,7 @@ X_OBJS= \
$(DIROBJ)\ssh.obj \
$(DIROBJ)\sslgen.obj \
$(DIROBJ)\ssluse.obj \
+ $(DIROBJ)\strdup.obj \
$(DIROBJ)\strequal.obj \
$(DIROBJ)\strerror.obj \
$(DIROBJ)\strtok.obj \