summaryrefslogtreecommitdiff
path: root/maketgz
diff options
context:
space:
mode:
authorAlessandro Ghedini <ghedo@debian.org>2017-08-12 12:27:23 +0100
committerAlessandro Ghedini <ghedo@debian.org>2017-08-12 12:27:23 +0100
commitbdd033d6e4a13df5b45f2628db5738f82ca6b413 (patch)
treecf888efddf7f3cf7dd714363ca0f477f2a59b4c6 /maketgz
parentd4e5ed3bd25935c7dc74a5fd183032d7649d2db8 (diff)
New upstream version 7.55.0
Diffstat (limited to 'maketgz')
-rwxr-xr-xmaketgz37
1 files changed, 20 insertions, 17 deletions
diff --git a/maketgz b/maketgz
index 8d117e68..e377c9b7 100755
--- a/maketgz
+++ b/maketgz
@@ -9,7 +9,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2016, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2017, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -67,8 +67,8 @@ if test -z "$only"; then
PLIST="$PLIST$ext"
fi
-# requires a date command that knows -u for UTC time zone
-datestamp=`LC_TIME=C date -u`
+# requires a date command that knows + for format
+datestamp=`date +"%F"`
# Replace version number in header file:
sed -i -e 's/^#define LIBCURL_VERSION .*/#define LIBCURL_VERSION "'$libversion'"/g' \
@@ -90,14 +90,6 @@ if test -n "$only"; then
exit;
fi
-# Generate VC7, VC8, VC9, VC10, VC11, VC12 and VC14 versions from the VC6
-# Makefile versions
-for ver in vc7 vc8 vc9 vc10 vc11 vc12 vc14; do
- make -f Makefile.dist $ver
- mv src/Makefile.$ver src/Makefile.$ver.dist
- mv lib/Makefile.$ver lib/Makefile.$ver.dist
-done
-
echo "curl version $curlversion"
echo "libcurl version $libversion"
echo "libcurl numerical $numeric"
@@ -141,6 +133,17 @@ fi
############################################################################
#
+# Modify the man pages to display the version number and date.
+#
+
+echo "update man pages"
+./scripts/updatemanpages.pl $version
+
+# make the generated file newer than the man page
+touch src/tool_hugehelp.c
+
+############################################################################
+#
# Update the IDE files
echo "make vc-ide"
make -s vc-ide
@@ -168,12 +171,12 @@ gzip -dc $targz | bzip2 --best > $bzip2
############################################################################
#
-# Now make an lzma archive from the tar.gz original
+# Now make an xz archive from the tar.gz original
#
-lzma="curl-$version.tar.lzma"
-echo "Generating $lzma"
-gzip -dc $targz | lzma --best - > $lzma
+xz="curl-$version.tar.xz"
+echo "Generating $xz"
+gzip -dc $targz | xz -6e - > $xz
############################################################################
#
@@ -199,7 +202,7 @@ makezip
echo "------------------"
echo "maketgz report:"
echo ""
-ls -l $targz $bzip2 $zip $lzma
+ls -l $targz $bzip2 $zip $xz
echo "Run this:"
-echo "gpg -b -a $targz && gpg -b -a $bzip2 && gpg -b -a $zip && gpg -b -a $lzma"
+echo "gpg -b -a $targz && gpg -b -a $bzip2 && gpg -b -a $zip && gpg -b -a $xz"