summaryrefslogtreecommitdiff
path: root/tests/unit/Makefile.am
diff options
context:
space:
mode:
authorRamakrishnan Muthukrishnan <vu3rdd@gmail.com>2011-07-30 17:23:29 +0530
committerRamakrishnan Muthukrishnan <vu3rdd@gmail.com>2011-07-30 17:23:29 +0530
commitf73f43d590cfcdf3bab0ef0bfb34ff0f81e1acb5 (patch)
treea9805b9e8e977b80dec75690f54a893df9303dec /tests/unit/Makefile.am
parent20c46e563f2693b7ace8b12f9a686460d35c54f6 (diff)
Imported Upstream version 7.21.7
Diffstat (limited to 'tests/unit/Makefile.am')
-rw-r--r--tests/unit/Makefile.am27
1 files changed, 9 insertions, 18 deletions
diff --git a/tests/unit/Makefile.am b/tests/unit/Makefile.am
index bdee6c10..aa74dc1a 100644
--- a/tests/unit/Makefile.am
+++ b/tests/unit/Makefile.am
@@ -40,7 +40,7 @@ INCLUDES = -I$(top_builddir)/include/curl \
-I$(top_srcdir)/include \
-I$(top_builddir)/lib \
-I$(top_srcdir)/lib \
- -I$(top_srcdir)/tests/libtest \
+ -I$(top_srcdir)/tests/libtest \
-I$(top_builddir)/ares \
-I$(top_srcdir)/ares
else
@@ -48,30 +48,21 @@ INCLUDES = -I$(top_builddir)/include/curl \
-I$(top_builddir)/include \
-I$(top_srcdir)/include \
-I$(top_builddir)/lib \
- -I$(top_srcdir)/lib \
- -I$(top_srcdir)/tests/libtest
+ -I$(top_srcdir)/lib \
+ -I$(top_srcdir)/tests/libtest
endif
-if CURLDEBUG
-
EXTRA_DIST = Makefile.inc
-LDADD = $(top_builddir)/tests/libtest/first.o $(top_builddir)/lib/libcurlu.la \
- @CURL_LIBS@
+LDADD = $(top_builddir)/lib/libcurlu.la @LDFLAGS@ @LIBCURL_LIBS@ @LIBS@
DEPENDENCIES = $(top_builddir)/lib/libcurlu.la
+AM_CPPFLAGS = -DUNITTESTS
-# Makefile.inc provides the source defines (TESTUTIL, SUPPORTFILES,
-# noinst_PROGRAMS, lib*_SOURCES, and lib*_CFLAGS)
+# Makefile.inc provides neat definitions
include Makefile.inc
-if NO_UNDEFINED
-# The -no-undefined flag is crucial to build fine on some platforms
-UNDEF = -no-undefined
-endif
-
-
+if BUILD_UNITTESTS
+noinst_PROGRAMS = $(UNITPROGS)
else
-# do nothing if debug was not enabled
-all:
-
+noinst_PROGRAMS =
endif