summaryrefslogtreecommitdiff
path: root/winbuild
diff options
context:
space:
mode:
authorAlessandro Ghedini <alessandro@ghedini.me>2013-02-11 13:29:16 +0100
committerAlessandro Ghedini <alessandro@ghedini.me>2013-02-11 13:29:16 +0100
commit579d668f74ce35a997c56f9fd831016ed103d4ac (patch)
tree04316f84e5b6ffac55f1492d8a371e7f2ccd0a3c /winbuild
parentcc228a68fc4d70a60d371f66640e1d9ed6491886 (diff)
Imported Upstream version 7.29.0
Diffstat (limited to 'winbuild')
-rw-r--r--winbuild/Makefile.vc5
-rw-r--r--winbuild/MakefileBuild.vc15
2 files changed, 12 insertions, 8 deletions
diff --git a/winbuild/Makefile.vc b/winbuild/Makefile.vc
index bc93c4b5..bc428326 100644
--- a/winbuild/Makefile.vc
+++ b/winbuild/Makefile.vc
@@ -40,11 +40,10 @@ CFGSET=true
!INCLUDE "../lib/Makefile.inc"
LIBCURL_OBJS=$(CSOURCES:.c=.obj)
-top_srcdir=..
!INCLUDE "../src/Makefile.inc"
-# hugehelp has a special rule
-CURL_OBJS=$(CURL_CFILES:hugehelp.c=)
+# tool_hugehelp has a special rule
+CURL_OBJS=$(CURL_CFILES:tool_hugehelp.c=)
CURL_OBJS=$(CURL_OBJS:.c=.obj)
diff --git a/winbuild/MakefileBuild.vc b/winbuild/MakefileBuild.vc
index 7e2904bb..1f670104 100644
--- a/winbuild/MakefileBuild.vc
+++ b/winbuild/MakefileBuild.vc
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1999 - 2012, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1999 - 2013, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -374,8 +374,13 @@ clean:
!include CURL_OBJS.inc
!include LIBCURL_OBJS.inc
+!IF "$(AS_DLL)" == "true"
+LIB_OBJS = $(LIBCURL_OBJS) $(RESOURCE)
+!ELSE
LIB_OBJS = $(LIBCURL_OBJS)
-EXE_OBJS = $(CURL_OBJS)
+!ENDIF
+
+EXE_OBJS = $(CURL_OBJS) $(CURL_DIROBJ)\curl.res
all : $(TARGET) $(PROGRAM_NAME)
@@ -454,7 +459,7 @@ CURL_LIBCURL_LIBNAME=$(LIB_NAME_IMP)
!ENDIF
!ENDIF
-CURL_FROM_LIBCURL=$(CURL_DIROBJ)\hugehelp.obj \
+CURL_FROM_LIBCURL=$(CURL_DIROBJ)\tool_hugehelp.obj \
$(CURL_DIROBJ)\nonblock.obj \
$(CURL_DIROBJ)\rawstr.obj \
$(CURL_DIROBJ)\strtoofft.obj
@@ -466,8 +471,8 @@ $(PROGRAM_NAME): $(CURL_DIROBJ) $(CURL_FROM_LIBCURL) $(EXE_OBJS)
{$(CURL_SRC_DIR)\}.c{$(CURL_DIROBJ)\}.obj:
$(CC) $(CURL_CFLAGS) /Fo"$@" $<
-$(CURL_DIROBJ)\hugehelp.obj: $(CURL_SRC_DIR)\hugehelp.c
- $(CURL_CC) $(CURL_CFLAGS) /Zm200 /Fo"$@" $(CURL_SRC_DIR)\hugehelp.c
+$(CURL_DIROBJ)\tool_hugehelp.obj: $(CURL_SRC_DIR)\tool_hugehelp.c
+ $(CURL_CC) $(CURL_CFLAGS) /Zm200 /Fo"$@" $(CURL_SRC_DIR)\tool_hugehelp.c
$(CURL_DIROBJ)\nonblock.obj: ../lib/nonblock.c
$(CURL_CC) $(CURL_CFLAGS) /Fo"$@" ../lib/nonblock.c
$(CURL_DIROBJ)\rawstr.obj: ../lib/rawstr.c