summaryrefslogtreecommitdiff
path: root/winbuild
diff options
context:
space:
mode:
authorAlessandro Ghedini <alessandro@ghedini.me>2015-08-12 10:34:59 +0200
committerAlessandro Ghedini <alessandro@ghedini.me>2015-08-12 10:34:59 +0200
commit9456f51adb76b83ceb4b95c8481325de62b25ad2 (patch)
treee5cfc1f4bc28cd81e93a96f9707a0efb143d278a /winbuild
parentdbada9f3efae6d9d47b24d0fc06b31d5c48e59a9 (diff)
Imported Upstream version 7.44.0
Diffstat (limited to 'winbuild')
-rw-r--r--winbuild/BUILD.WINDOWS.txt15
-rw-r--r--winbuild/Makefile.vc2
-rw-r--r--winbuild/MakefileBuild.vc2
3 files changed, 14 insertions, 5 deletions
diff --git a/winbuild/BUILD.WINDOWS.txt b/winbuild/BUILD.WINDOWS.txt
index 600f7374..1556fe65 100644
--- a/winbuild/BUILD.WINDOWS.txt
+++ b/winbuild/BUILD.WINDOWS.txt
@@ -1,5 +1,5 @@
-Building with Visual C++, prerequises
-=====================================
+Building with Visual C++, prerequisites
+=======================================
This document describes how to compile, build and install curl and libcurl
from sources using the Visual C++ build tool. To build with VC++, you will
@@ -58,7 +58,7 @@ a directory named using the options given to the nmake call.
nmake /f Makefile.vc mode=<static or dll> <options>
where <options> is one or many of:
- VC=<6,7,8,9,10,11,12> - VC versions
+ VC=<6,7,8,9,10,11,12,14> - VC versions
WITH_DEVEL=<path> - Paths for the development files (SSL, zlib, etc.)
Defaults to sibbling directory deps: ../deps
Libraries can be fetched at http://windows.php.net/downloads/php-sdk/deps/
@@ -87,3 +87,12 @@ therefore rarely tested. When passing RTLIBCFG for a configuration that was
already built but not with that option, or if the option was specified
differently, you must destroy the build directory containing the configuration
so that nmake can build it from scratch.
+
+Legacy Windows and SSL
+======================
+When you build curl using the build files in this directory the default SSL
+backend will be WinSSL (Windows SSPI, more specifically Schannel), the native
+SSL library that comes with the Windows OS. WinSSL in Windows <= XP is not able
+to connect to servers that no longer support the legacy handshakes and
+algorithms used by those versions. If you will be using curl in one of those
+earlier versions of Windows you should choose another SSL backend like OpenSSL.
diff --git a/winbuild/Makefile.vc b/winbuild/Makefile.vc
index 21e1614a..5b726cd5 100644
--- a/winbuild/Makefile.vc
+++ b/winbuild/Makefile.vc
@@ -15,7 +15,7 @@ CFGSET=true
!MESSAGE Usage: nmake /f Makefile.vc mode=<static or dll> <options>
!MESSAGE where <options> is one or many of:
-!MESSAGE VC=<6,7,8,9,10,11,12> - VC versions
+!MESSAGE VC=<6,7,8,9,10,11,12,14> - VC versions
!MESSAGE WITH_DEVEL=<path> - Paths for the development files (SSL, zlib, etc.)
!MESSAGE Defaults to sibbling directory deps: ../deps
!MESSAGE Libraries can be fetched at http://pecl2.php.net/downloads/php-windows-builds/
diff --git a/winbuild/MakefileBuild.vc b/winbuild/MakefileBuild.vc
index 2cad15c9..28d40baa 100644
--- a/winbuild/MakefileBuild.vc
+++ b/winbuild/MakefileBuild.vc
@@ -22,7 +22,7 @@
###########################################################################
#
-# Makefile for building libcurl with MSVC 6, 7, 8, 9, 10, 11 and 12
+# Makefile for building libcurl with MSVC 6, 7, 8, 9, 10, 11, 12 and 14
#
# Usage: see usage message below
# Should be invoked from winbuild directory