summaryrefslogtreecommitdiff
path: root/winbuild
diff options
context:
space:
mode:
authorAlessandro Ghedini <alessandro@ghedini.me>2014-05-21 12:49:50 +0200
committerAlessandro Ghedini <alessandro@ghedini.me>2014-05-21 12:49:50 +0200
commita87e878305851b0d8c48f5c06370ab8d0725560a (patch)
tree6d055277be1b91d8af0a44e9e729e68a4c8251e5 /winbuild
parent406f619a33e3b0e01cc04e8e77a90ee93b229602 (diff)
Imported Upstream version 7.37.0
Diffstat (limited to 'winbuild')
-rw-r--r--winbuild/BUILD.WINDOWS.txt16
-rw-r--r--winbuild/MakefileBuild.vc5
2 files changed, 15 insertions, 6 deletions
diff --git a/winbuild/BUILD.WINDOWS.txt b/winbuild/BUILD.WINDOWS.txt
index 06d7b2fb..757c41f5 100644
--- a/winbuild/BUILD.WINDOWS.txt
+++ b/winbuild/BUILD.WINDOWS.txt
@@ -1,18 +1,24 @@
Building with Visual C++, prerequises
=====================================
+
This document describes how to compile, build and install curl and libcurl
from sources using the Visual C++ build tool. To build with VC++, you will
of course have to first install VC++. The minimum required version of
- VC is 6 (part of Visual Studio 6). However using a more recent version like
- 2008 (vc9) is strongly recommended.
+ VC is 6 (part of Visual Studio 6). However using a more recent version is
+ strongly recommended.
VC++ is also part of the Windows Platform SDK. You do not have to install
the full Visual Studio or Visual C++ if all you want is to build curl.
- The Platform SDK can be fetched here, freely:
+ The latest Platform SDK can be downloaded freely from:
http://msdn.microsoft.com/en-us/windows/bb980924
+ If you are building with VC6 then you will also need the February 2003
+ Edition of the Platform SDK which can be downloaded from:
+
+ http://www.microsoft.com/en-us/download/details.aspx?id=12261
+
If you wish to support zlib, openssl, ssh2, you will have to download
them separately and copy them to the deps directory as shown below:
@@ -55,7 +61,7 @@ where <options> is one or many of:
VC=<6,7,8,9,10,11,12> - VC versions
WITH_DEVEL=<path> - Paths for the development files (SSL, zlib, etc.)
Defaults to sibbling directory deps: ../deps
- Libraries can be fetched at http://pecl2.php.net/downloads/php-windows-builds/
+ Libraries can be fetched at http://windows.php.net/downloads/php-sdk/deps/
Uncompress them into the deps folder.
WITH_SSL=<dll or static> - Enable OpenSSL support, DLL or static
WITH_ZLIB=<dll or static> - Enable zlib support, DLL or static
@@ -68,4 +74,4 @@ where <options> is one or many of:
ENABLE_WINSSL=<yes or no> - Enable native Windows SSL support, defaults to yes
GEN_PDB=<yes or no> - Generate Program Database (debug symbols for release build)
DEBUG=<yes or no> - Debug builds
- MACHINE=<x86 or x64> - Target architecture (default is x86) \ No newline at end of file
+ MACHINE=<x86 or x64> - Target architecture (default is x86)
diff --git a/winbuild/MakefileBuild.vc b/winbuild/MakefileBuild.vc
index 37767a9b..58ed7089 100644
--- a/winbuild/MakefileBuild.vc
+++ b/winbuild/MakefileBuild.vc
@@ -466,7 +466,8 @@ CURL_LIBCURL_LIBNAME=$(LIB_NAME_IMP)
CURL_FROM_LIBCURL=$(CURL_DIROBJ)\tool_hugehelp.obj \
$(CURL_DIROBJ)\nonblock.obj \
$(CURL_DIROBJ)\rawstr.obj \
- $(CURL_DIROBJ)\strtoofft.obj
+ $(CURL_DIROBJ)\strtoofft.obj \
+ $(CURL_DIROBJ)\warnless.obj
$(PROGRAM_NAME): $(CURL_DIROBJ) $(CURL_FROM_LIBCURL) $(EXE_OBJS)
$(CURL_LINK) $(CURL_LFLAGS) $(CURL_LIBCURL_LIBNAME) $(WIN_LIBS) $(CURL_FROM_LIBCURL) $(EXE_OBJS)
@@ -483,6 +484,8 @@ $(CURL_DIROBJ)\rawstr.obj: ../lib/rawstr.c
$(CURL_CC) $(CURL_CFLAGS) /Fo"$@" ../lib/rawstr.c
$(CURL_DIROBJ)\strtoofft.obj: ../lib/strtoofft.c
$(CURL_CC) $(CURL_CFLAGS) /Fo"$@" ../lib/strtoofft.c
+$(CURL_DIROBJ)\warnless.obj: ../lib/warnless.c
+ $(CURL_CC) $(CURL_CFLAGS) /Fo"$@" ../lib/warnless.c
$(CURL_DIROBJ)\curl.res: $(CURL_SRC_DIR)\curl.rc
rc $(CURL_RC_FLAGS)