summaryrefslogtreecommitdiff
path: root/winbuild
diff options
context:
space:
mode:
authorAlessandro Ghedini <ghedo@debian.org>2019-07-12 20:16:40 +0100
committerAlessandro Ghedini <ghedo@debian.org>2019-07-12 20:16:40 +0100
commitb10ac967894740f12278c3918fe7d94394225740 (patch)
tree772c5b0efc5973a41ba5920d9d7bf31f00cac5f0 /winbuild
parent6a4d7f25b9ff57641a0c24d03488ac5b1e95ec5c (diff)
New upstream version 7.65.1
Diffstat (limited to 'winbuild')
-rw-r--r--winbuild/Makefile.vc6
-rw-r--r--winbuild/MakefileBuild.vc6
-rwxr-xr-xwinbuild/gen_resp_file.bat36
3 files changed, 36 insertions, 12 deletions
diff --git a/winbuild/Makefile.vc b/winbuild/Makefile.vc
index 94ce8db3..26ab9069 100644
--- a/winbuild/Makefile.vc
+++ b/winbuild/Makefile.vc
@@ -168,12 +168,6 @@ USE_MBEDTLS = true
MBEDTLS = $(WITH_MBEDTLS)
!ENDIF
-!IF ( "$(USE_SSL)"=="true" && "$(USE_WINSSL)"=="true" ) \
- || ( "$(USE_SSL)"=="true" && "$(USE_MBEDTLS)"=="true" ) \
- || ( "$(USE_MBEDTLS)"=="true" && "$(USE_WINSSL)"=="true" )
-!ERROR SSL, MBEDTLS and WINSSL are mutual exclusive options.
-!ENDIF
-
!IF "$(WITH_CARES)"=="dll"
USE_CARES = true
CARES = dll
diff --git a/winbuild/MakefileBuild.vc b/winbuild/MakefileBuild.vc
index 3125c21b..8d942b75 100644
--- a/winbuild/MakefileBuild.vc
+++ b/winbuild/MakefileBuild.vc
@@ -479,6 +479,12 @@ CFLAGS = $(CFLAGS) $(CFLAGS_PDB) /Fd"$(LIB_DIROBJ)\$(PDB)"
LFLAGS = $(LFLAGS) $(LFLAGS_PDB)
!ENDIF
+!IF ( "$(USE_SSL)"=="true" && "$(USE_WINSSL)"=="true" ) \
+ || ( "$(USE_SSL)"=="true" && "$(USE_MBEDTLS)"=="true" ) \
+ || ( "$(USE_MBEDTLS)"=="true" && "$(USE_WINSSL)"=="true" )
+CFLAGS = $(CFLAGS) /DCURL_WITH_MULTI_SSL
+!ENDIF
+
LIB_DIROBJ = ..\builds\$(CONFIG_NAME_LIB)-obj-lib
CURL_DIROBJ = ..\builds\$(CONFIG_NAME_LIB)-obj-curl
DIRDIST = ..\builds\$(CONFIG_NAME_LIB)\
diff --git a/winbuild/gen_resp_file.bat b/winbuild/gen_resp_file.bat
index c640cee0..79a27acf 100755
--- a/winbuild/gen_resp_file.bat
+++ b/winbuild/gen_resp_file.bat
@@ -1,8 +1,32 @@
-@echo OFF
-@if exist %OUTFILE% (
- del %OUTFILE%
+@echo off
+rem ***************************************************************************
+rem * _ _ ____ _
+rem * Project ___| | | | _ \| |
+rem * / __| | | | |_) | |
+rem * | (__| |_| | _ <| |___
+rem * \___|\___/|_| \_\_____|
+rem *
+rem * Copyright (C) 2011 - 2019, Daniel Stenberg, <daniel@haxx.se>, et al.
+rem *
+rem * This software is licensed as described in the file COPYING, which
+rem * you should have received as part of this distribution. The terms
+rem * are also available at https://curl.haxx.se/docs/copyright.html.
+rem *
+rem * You may opt to use, copy, modify, merge, publish, distribute and/or sell
+rem * copies of the Software, and permit persons to whom the Software is
+rem * furnished to do so, under the terms of the COPYING file.
+rem *
+rem * This software is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY
+rem * KIND, either express or implied.
+rem *
+rem ***************************************************************************
+
+if exist %OUTFILE% (
+ del %OUTFILE%
)
-@echo %MACRO_NAME% = \> %OUTFILE%
-@for %%i in (%*) do @echo %DIROBJ%/%%i \>> %OUTFILE%
-@echo. >> %OUTFILE%
+
+echo %MACRO_NAME% = \> %OUTFILE%
+for %%i in (%*) do echo %DIROBJ%/%%i \>> %OUTFILE%
+echo. >> %OUTFILE%
+
:END