summaryrefslogtreecommitdiff
path: root/winbuild
diff options
context:
space:
mode:
authorAlessandro Ghedini <ghedo@debian.org>2018-07-11 22:37:26 +0100
committerAlessandro Ghedini <ghedo@debian.org>2018-07-11 22:37:26 +0100
commitd1a513ee44dba8dae727e1975ebcfa20966fec8f (patch)
treeaa35c8d732f77bebca871a3070f4002636d1ce79 /winbuild
parent0b0cdd3061d45cdb1c6320fda06bb77f5c953fea (diff)
New upstream version 7.61.0
Diffstat (limited to 'winbuild')
-rw-r--r--winbuild/MakefileBuild.vc6
-rwxr-xr-xwinbuild/gen_resp_file.bat4
2 files changed, 7 insertions, 3 deletions
diff --git a/winbuild/MakefileBuild.vc b/winbuild/MakefileBuild.vc
index bf79db37..019a414a 100644
--- a/winbuild/MakefileBuild.vc
+++ b/winbuild/MakefileBuild.vc
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1999 - 2017, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1999 - 2018, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -352,6 +352,8 @@ GEN_PDB = true
!IFDEF EMBED_MANIFEST
MANIFESTTOOL = $(MT) -manifest $(DIRDIST)\bin\$(PROGRAM_NAME).manifest -outputresource:$(DIRDIST)\bin\$(PROGRAM_NAME);1
+!ELSE
+CURL_RC_FLAGS = $(CURL_RC_FLAGS) /dCURL_EMBED_MANIFEST
!ENDIF
# Runtime library configuration
@@ -502,7 +504,7 @@ package: $(TARGET)
@-$(ZIP) -9 -q -r ..\$(CONFIG_NAME_LIB).zip .>nul 2<&1
@cd $(MAKEDIR)
-$(TARGET): $(LIB_OBJS) $(LIB_DIROBJ) $(DISTDIR)
+$(TARGET): $(LIB_OBJS) $(LIB_DIROBJ) $(DIRDIST)
@echo Using SSL: $(USE_SSL)
@echo Using NGHTTP2: $(USE_NGHTTP2)
@echo Using c-ares: $(USE_CARES)
diff --git a/winbuild/gen_resp_file.bat b/winbuild/gen_resp_file.bat
index 434f3696..c640cee0 100755
--- a/winbuild/gen_resp_file.bat
+++ b/winbuild/gen_resp_file.bat
@@ -1,5 +1,7 @@
@echo OFF
-@del %OUTFILE%
+@if exist %OUTFILE% (
+ del %OUTFILE%
+)
@echo %MACRO_NAME% = \> %OUTFILE%
@for %%i in (%*) do @echo %DIROBJ%/%%i \>> %OUTFILE%
@echo. >> %OUTFILE%