summaryrefslogtreecommitdiff
path: root/winbuild
diff options
context:
space:
mode:
authorAlessandro Ghedini <ghedo@debian.org>2020-02-09 13:08:33 +0000
committerAlessandro Ghedini <ghedo@debian.org>2020-02-09 13:08:33 +0000
commitfd1d5a17d8860d992d5022826b86898e22847bfb (patch)
treee6734b853d299aa98a3653cebf0233a712c07009 /winbuild
parentcbefed98f8c0f58b41921fcde1aa741078e803d7 (diff)
New upstream version 7.68.0
Diffstat (limited to 'winbuild')
-rw-r--r--winbuild/BUILD.WINDOWS.txt6
-rw-r--r--winbuild/MakefileBuild.vc7
2 files changed, 11 insertions, 2 deletions
diff --git a/winbuild/BUILD.WINDOWS.txt b/winbuild/BUILD.WINDOWS.txt
index 1ede14f0..0e88e644 100644
--- a/winbuild/BUILD.WINDOWS.txt
+++ b/winbuild/BUILD.WINDOWS.txt
@@ -114,6 +114,12 @@ already built but not with that option, or if the option was specified
differently, you must destroy the build directory containing the configuration
so that nmake can build it from scratch.
+Building your own application with a static libcurl
+===================================================
+When building an application that uses the static libcurl library on Windows,
+you must define CURL_STATICLIB. Otherwise the linker will look for dynamic
+import symbols.
+
Legacy Windows and SSL
======================
When you build curl using the build files in this directory the default SSL
diff --git a/winbuild/MakefileBuild.vc b/winbuild/MakefileBuild.vc
index 8267250c..4e39be66 100644
--- a/winbuild/MakefileBuild.vc
+++ b/winbuild/MakefileBuild.vc
@@ -61,11 +61,11 @@ CC = cl.exe
!IF "$(VC)"=="6"
CC_NODEBUG = $(CC) /O2 /DNDEBUG
CC_DEBUG = $(CC) /Od /Gm /Zi /D_DEBUG /GZ
-CFLAGS = /I. /I../lib /I../include /nologo /W4 /wd4127 /GX /DWIN32 /YX /FD /c /DBUILDING_LIBCURL
+CFLAGS = /I. /I../lib /I../include /nologo /W4 /GX /DWIN32 /YX /FD /c /DBUILDING_LIBCURL
!ELSE
CC_NODEBUG = $(CC) /O2 /DNDEBUG
CC_DEBUG = $(CC) /Od /D_DEBUG /RTC1 /Z7 /LDd
-CFLAGS = /I. /I ../lib /I../include /nologo /W4 /wd4127 /EHsc /DWIN32 /FD /c /DBUILDING_LIBCURL
+CFLAGS = /I. /I ../lib /I../include /nologo /W4 /EHsc /DWIN32 /FD /c /DBUILDING_LIBCURL
!ENDIF
LFLAGS = /nologo /machine:$(MACHINE)
@@ -222,6 +222,9 @@ CARES = static
!IFDEF USE_CARES
CARES_CFLAGS = /DUSE_ARES /I"$(CARES_INC_DIR)"
+!IF "$(CARES)"=="static"
+CARES_CFLAGS = $(CARES_CFLAGS) /DCARES_STATICLIB
+!ENDIF
!ENDIF