summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2024-03-13 12:23:43 +0000
committerColin Watson <cjwatson@debian.org>2024-03-13 12:23:43 +0000
commit0cd10b5405832373e42bdd95106aa92592e53075 (patch)
tree67de7c5ff24dcd0fd58b446f2675b06dd2df3ea1
parent19e5251e961cff9280f486dbda124580d8eac69d (diff)
parent2f49629dfdc096b6c947040d81a496330ed31467 (diff)
Add missing #include to db_dump185
Closes: #1066389
-rw-r--r--db_dump185/db_dump185.c1
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/build-outside-glibc.patch4
-rw-r--r--debian/patches/db_dump185.patch15
5 files changed, 19 insertions, 11 deletions
diff --git a/db_dump185/db_dump185.c b/db_dump185/db_dump185.c
index 2fb3cc5..5e82fc4 100644
--- a/db_dump185/db_dump185.c
+++ b/db_dump185/db_dump185.c
@@ -20,6 +20,7 @@ static char copyright[] =
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#include <unistd.h>
#include <db.h>
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 77ae5b0..5379831 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-953d0a729892c937f25085e4583aae69b4c4e3da
-953d0a729892c937f25085e4583aae69b4c4e3da
+2f49629dfdc096b6c947040d81a496330ed31467
+2f49629dfdc096b6c947040d81a496330ed31467
38a03f9f9593a1185c8996ef1024346ae12224aa
38a03f9f9593a1185c8996ef1024346ae12224aa
db1-compat_2.1.3.orig.tar.gz
diff --git a/debian/changelog b/debian/changelog
index 202ff9d..eee3515 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+db1-compat (2.1.3-25) UNRELEASED; urgency=medium
+
+ * Add missing #include to db_dump185 (closes: #1066389).
+
+ -- Colin Watson <cjwatson@debian.org> Wed, 13 Mar 2024 12:22:49 +0000
+
db1-compat (2.1.3-24) unstable; urgency=medium
* Set Rules-Requires-Root: no.
diff --git a/debian/patches/build-outside-glibc.patch b/debian/patches/build-outside-glibc.patch
index 30131f4..cc8fc08 100644
--- a/debian/patches/build-outside-glibc.patch
+++ b/debian/patches/build-outside-glibc.patch
@@ -8,8 +8,8 @@ Last-Update: 2012-06-22
Patch-Name: build-outside-glibc.patch
---
- Makefile | 71 ++++++++++++++++++----------------------------------------------
- Versions | 9 ++++----
+ Makefile | 71 ++++++++++++++++----------------------------------------
+ Versions | 9 +++----
2 files changed, 25 insertions(+), 55 deletions(-)
diff --git a/Makefile b/Makefile
diff --git a/debian/patches/db_dump185.patch b/debian/patches/db_dump185.patch
index 9d9e156..bcf47d8 100644
--- a/debian/patches/db_dump185.patch
+++ b/debian/patches/db_dump185.patch
@@ -1,4 +1,4 @@
-From 953d0a729892c937f25085e4583aae69b4c4e3da Mon Sep 17 00:00:00 2001
+From 2f49629dfdc096b6c947040d81a496330ed31467 Mon Sep 17 00:00:00 2001
From: Julian Gilbey <jdg@debian.org>
Date: Tue, 14 Jan 2014 02:08:55 +0000
Subject: Add db_dump185 utility
@@ -8,14 +8,14 @@ This provides dump compatibility with legacy database files.
Author: Colin Watson <cjwatson@debian.org>
Bug-Debian: http://bugs.debian.org/353637
Forwarded: no
-Last-Update: 2012-06-22
+Last-Update: 2024-03-13
Patch-Name: db_dump185.patch
---
Makefile | 7 +-
- db_dump185/db_dump185.1 | 956 ++++++++++++++++++++++++++++++++++++++++++++++++
- db_dump185/db_dump185.c | 355 ++++++++++++++++++
- 3 files changed, 1317 insertions(+), 1 deletion(-)
+ db_dump185/db_dump185.1 | 956 ++++++++++++++++++++++++++++++++++++++++
+ db_dump185/db_dump185.c | 356 +++++++++++++++
+ 3 files changed, 1318 insertions(+), 1 deletion(-)
create mode 100644 db_dump185/db_dump185.1
create mode 100644 db_dump185/db_dump185.c
@@ -1009,10 +1009,10 @@ index 0000000..9fb305d
+.Sa
diff --git a/db_dump185/db_dump185.c b/db_dump185/db_dump185.c
new file mode 100644
-index 0000000..2fb3cc5
+index 0000000..5e82fc4
--- /dev/null
+++ b/db_dump185/db_dump185.c
-@@ -0,0 +1,355 @@
+@@ -0,0 +1,356 @@
+/*-
+ * See the file LICENSE for redistribution information.
+ *
@@ -1035,6 +1035,7 @@ index 0000000..2fb3cc5
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
++#include <unistd.h>
+
+#include <db.h>
+