summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2022-11-25 11:28:56 +0000
committerSimon McVittie <smcv@debian.org>2022-11-25 11:29:00 +0000
commit07d15f7dcdf0142a115cd3ed614a12ceef534b35 (patch)
tree5b678d24e2fbc6a938539b2570d1fd800b7d98d2
parentf1941b7ed8cdd693f39209a0e73737023177c114 (diff)
Increase an arbitrary test timeoutdebian/1.3.2-3
This should avoid intermittent FTBFS on slower buildds such as alpha, mips64el and riscv64. Meson defaults to allowing 30 seconds per test-case, but test-import-repeatedly takes about 18 seconds on alpha, 29 to 30 seconds on riscv64 and 12 to 30 seconds on mips64el, so this is too short. Closes: #1024210
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules8
2 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a7e497f..94a5910 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dbus-python (1.3.2-3) unstable; urgency=medium
+
+ * Increase an arbitrary test timeout to avoid intermittent FTBFS on
+ slower buildds such as alpha, mips64el and riscv64 (Closes: #1024210)
+
+ -- Simon McVittie <smcv@debian.org> Fri, 25 Nov 2022 11:28:44 +0000
+
dbus-python (1.3.2-2) unstable; urgency=medium
[ Debian Janitor ]
diff --git a/debian/rules b/debian/rules
index 65e6f9b..410cf78 100755
--- a/debian/rules
+++ b/debian/rules
@@ -65,7 +65,13 @@ override_dh_auto_test-arch:
LC_ALL=C.UTF-8 \
PYTHON=/usr/bin/python$$x \
VERBOSE=1 \
- dh_auto_test --no-parallel --arch --builddirectory=build-$$x; \
+ dh_auto_test \
+ --no-parallel \
+ --arch \
+ --builddirectory=build-$$x \
+ -- \
+ --timeout-multiplier 3 \
+ ; \
done
override_dh_auto_test-indep:
: