summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2012-01-24 20:37:50 +0000
committerSimon McVittie <smcv@debian.org>2012-01-24 20:37:50 +0000
commit0c05ab5fb57576b9d0de29a134cebf8792d5e0ce (patch)
treef600405656a8f75f985693a6ee56f14e744d6f93
parentbf13a2c6769cf72d42dd6a947972c0ff9113d9e0 (diff)
New upstream version 1.0.0
* New upstream version 1.0.0 - increase Python requirement to 2.6
-rw-r--r--debian/changelog14
-rw-r--r--debian/control76
-rw-r--r--debian/python-dbus-dev.install2
-rw-r--r--debian/python-dbus.install3
-rw-r--r--debian/python3-dbus-dbg.install1
-rw-r--r--debian/python3-dbus.docs2
-rw-r--r--debian/python3-dbus.install3
-rwxr-xr-xdebian/rules37
8 files changed, 120 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 11e75c9..321b532 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,20 @@
-dbus-python (0.84.0-3) UNRELEASED; urgency=low
-
+dbus-python (1.0.0-1) UNRELEASED; urgency=low
+
+ * New upstream version 1.0.0
+ - increase Python requirement to 2.6
+ - build for Python 3 too
+ - split python-dbus-dev into a separate package to be shared between
+ versions
+ - make python-dbus depend on python-dbus-dev for now, to preserve
+ historical functionality (but packages which use it, like PyQt, should
+ switch to depending on it explicitly)
* Drop obsolete recommendation of python-gtk, which hasn't provided the
GLib main loop since before squeeze. Allow python-gi (also GLib main loop)
or python-qt4-dbus (Qt main loop) to satisfy the dependency instead
(Closes: #656230)
* Move to debhelper 9 compat and use dh
- -- Simon McVittie <smcv@debian.org> Tue, 24 Jan 2012 16:53:38 +0000
+ -- Simon McVittie <smcv@debian.org> Tue, 24 Jan 2012 19:07:26 +0000
dbus-python (0.84.0-2) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 3b1aee0..96e6f40 100644
--- a/debian/control
+++ b/debian/control
@@ -12,13 +12,16 @@ Build-Depends: autoconf,
dh-autoreconf,
python-all-dbg (>= 2.6.6-3~),
python-all-dev (>= 2.6.6-3~),
+ python3-all-dbg,
+ python3-all-dev,
libdbus-1-dev (>= 1.4),
libdbus-glib-1-dev (>= 0.71),
xmlto
Build-Depends-Indep: python-docutils,
python-epydoc (>= 3.0~beta1)
Standards-Version: 3.9.2
-X-Python-Version: >= 2.4
+X-Python-Version: >= 2.6
+X-Python3-Version: >= 3.2
Homepage: http://www.freedesktop.org/wiki/Software/DBusBindings#Python
Vcs-Git: git://anonscm.debian.org/git/pkg-utopia/dbus-python.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-utopia/dbus-python.git
@@ -26,9 +29,12 @@ Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-utopia/dbus-python.git
Package: python-dbus
Section: python
Architecture: any
+# Depends on python-dbus-dev for backwards compatibility, until packages
+# are fixed to depend on that directly
Depends: ${misc:Depends},
${python:Depends},
- ${shlibs:Depends}
+ ${shlibs:Depends},
+ python-dbus-dev
Recommends: python-gi | python-gobject-2 | python-qt4-dbus
Suggests: python-dbus-doc, python-dbus-dbg
Replaces: python2.4-dbus
@@ -46,20 +52,76 @@ Description: simple interprocess messaging system (Python interface)
.
See the dbus description for more information about D-Bus in general.
+Package: python3-dbus
+Section: python
+Architecture: any
+# Does not have Depends: python-dbus-dev because as a new package, it cannot
+# have backwards compatibility concerns
+Depends: ${misc:Depends},
+ ${python3:Depends},
+ ${shlibs:Depends}
+Recommends: python3-gi | python3-qt4-dbus
+Suggests: python-dbus-doc, python3-dbus-dbg
+Provides: ${python3:Provides}
+Description: simple interprocess messaging system (Python 3 interface)
+ D-Bus is a message bus, used for sending messages between applications.
+ Conceptually, it fits somewhere in between raw sockets and CORBA in
+ terms of complexity.
+ .
+ This package provides a Python 3 interface to D-Bus.
+ .
+ See the dbus description for more information about D-Bus in general.
+
+Package: python-dbus-dev
+Section: python
+Priority: optional
+Architecture: all
+Depends: ${misc:Depends}
+Breaks: python-dbus (<< 1.0),
+ python-dbus-common (<< 1.0)
+Replaces: python-dbus (<< 1.0),
+ python-dbus-common (<< 1.0)
+Description: main loop integration development files for python-dbus
+ D-Bus is a message bus, used for sending messages between applications.
+ Conceptually, it fits somewhere in between raw sockets and CORBA in
+ terms of complexity.
+ .
+ This package provides development files required to compile main-loop
+ integration modules for python-dbus, such as dbus.mainloop.qt provided
+ by PyQt. It is Python-version-independent: you must also depend on either
+ python-dbus or python3-dbus, if required.
+
Package: python-dbus-dbg
Section: debug
Priority: extra
Architecture: any
-Depends: python-dbus (= ${binary:Version}), python-dbg, ${shlibs:Depends}, ${misc:Depends}, ${python:Depends}
-Description: Debug build of the D-Bus Python interface
+Depends: python-dbg,
+ python-dbus (= ${binary:Version}),
+ ${shlibs:Depends},
+ ${misc:Depends},
+ ${python:Depends}
+Description: debug build of the D-Bus Python 2 interface
This package provides a version of the python-dbus package built for
- debugging versions of Python.
+ debugging versions of Python 2, and debug symbols for python-dbus.
+
+Package: python3-dbus-dbg
+Section: debug
+Priority: extra
+Architecture: any
+Depends: python3-dbg,
+ python3-dbus (= ${binary:Version}),
+ ${shlibs:Depends},
+ ${misc:Depends},
+ ${python:Depends}
+Description: debug build of the D-Bus Python 3 interface
+ This package provides a version of the python3-dbus package built for
+ debugging versions of Python 3, and debug symbols for python3-dbus.
Package: python-dbus-doc
Section: doc
Architecture: all
Depends: ${misc:Depends}
-Suggests: python-dbus
+Suggests: python-dbus | python3-dbus
Description: Documentation for the D-Bus Python interface
This package provides text and HTML documentation, and examples, for the
- python-dbus package.
+ python-dbus and python3-dbus packages.
diff --git a/debian/python-dbus-dev.install b/debian/python-dbus-dev.install
new file mode 100644
index 0000000..f3389d1
--- /dev/null
+++ b/debian/python-dbus-dev.install
@@ -0,0 +1,2 @@
+usr/lib/pkgconfig/dbus-python.pc
+usr/include/dbus-1.0/dbus/dbus-python.h
diff --git a/debian/python-dbus.install b/debian/python-dbus.install
index adc870b..8945a4b 100644
--- a/debian/python-dbus.install
+++ b/debian/python-dbus.install
@@ -1,7 +1,4 @@
usr/lib/python2.*/*-packages/_dbus_bindings.so
usr/lib/python2.*/*-packages/_dbus_glib_bindings.so
-usr/lib/python2.*/*-packages/*.py
usr/lib/python2.*/*-packages/dbus/*.py
usr/lib/python2.*/*-packages/dbus/*/*.py
-usr/lib/pkgconfig/dbus-python.pc
-usr/include/dbus-1.0/dbus/dbus-python.h
diff --git a/debian/python3-dbus-dbg.install b/debian/python3-dbus-dbg.install
new file mode 100644
index 0000000..bbca755
--- /dev/null
+++ b/debian/python3-dbus-dbg.install
@@ -0,0 +1 @@
+debian/tmp-dbg/usr/lib/python3/dist-packages/*.so usr/lib/python3/dist-packages
diff --git a/debian/python3-dbus.docs b/debian/python3-dbus.docs
new file mode 100644
index 0000000..50bd824
--- /dev/null
+++ b/debian/python3-dbus.docs
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/python3-dbus.install b/debian/python3-dbus.install
new file mode 100644
index 0000000..f5bac82
--- /dev/null
+++ b/debian/python3-dbus.install
@@ -0,0 +1,3 @@
+usr/lib/python3/dist-packages/*.so
+usr/lib/python3/dist-packages/dbus/*.py
+usr/lib/python3/dist-packages/dbus/*/*.py
diff --git a/debian/rules b/debian/rules
index ca61568..5bb626e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,9 +5,10 @@
# Copyright © 2012 Collabora Ltd.
PYVERS := $(shell pyversions --requested --version debian/control)
+PY3VERS := $(shell py3versions --requested --version debian/control)
PYDEFAULTVER := $(shell pyversions --default --version)
-FLAVOURS := $(patsubst %,%-dbg,$(PYVERS)) $(PYVERS)
+FLAVOURS := $(patsubst %,%-dbg,$(PYVERS) $(PY3VERS)) $(PYVERS) $(PY3VERS)
%:
dh $@ --with python2,autoreconf
@@ -36,7 +37,7 @@ override_dh_auto_build-indep:
override_dh_auto_test-arch:
:
-# set -e && for x in $(PYVERS); do \
+# set -e && for x in $(PYVERS) $(PY3VERS); do \
# PYTHON=/usr/bin/python$$x \
# dh_auto_test --arch --builddirectory=build-$$x; \
# done
@@ -61,8 +62,32 @@ override_dh_auto_install-arch:
debian/tmp/usr/lib/python$$x/dist-packages/_dbus_bindings_d.so; \
install debian/tmp-dbg/usr/lib/python$$x/dist-packages/_dbus_glib_bindings.so \
debian/tmp/usr/lib/python$$x/dist-packages/_dbus_glib_bindings_d.so; \
- rm -rf debian/tmp-dbg; \
done
+ set -e && for x in $(PY3VERS); do \
+ PYTHON=/usr/bin/python$$x \
+ dh_auto_install \
+ --arch \
+ --builddirectory=build-$$x \
+ --destdir=debian/tmp \
+ ; \
+ so=`/usr/bin/python$$x -c "print(__import__('sysconfig').get_config_var('SO'))"`; \
+ mv debian/tmp/usr/lib/python3/dist-packages/_dbus_bindings.so \
+ debian/tmp/usr/lib/python3/dist-packages/_dbus_bindings$$so; \
+ mv debian/tmp/usr/lib/python3/dist-packages/_dbus_glib_bindings.so \
+ debian/tmp/usr/lib/python3/dist-packages/_dbus_glib_bindings$$so; \
+ PYTHON=/usr/bin/python$$x-dbg \
+ dh_auto_install \
+ --arch \
+ --builddirectory=build-$$x-dbg \
+ --destdir=debian/tmp-dbg \
+ ; \
+ so=`/usr/bin/python$$x-dbg -c "print(__import__('sysconfig').get_config_var('SO'))"`; \
+ mv debian/tmp-dbg/usr/lib/python3/dist-packages/_dbus_bindings.so \
+ debian/tmp-dbg/usr/lib/python3/dist-packages/_dbus_bindings$$so; \
+ mv debian/tmp-dbg/usr/lib/python3/dist-packages/_dbus_glib_bindings.so \
+ debian/tmp-dbg/usr/lib/python3/dist-packages/_dbus_glib_bindings$$so; \
+ done
+
# do not install any docs, we copy those from the builddir
override_dh_auto_install-indep:
:
@@ -75,12 +100,14 @@ override_dh_install:
override_dh_installdocs-arch:
dh_installdocs --link-doc=python-dbus -ppython-dbus-dbg
+ dh_installdocs --link-doc=python3-dbus -ppython3-dbus-dbg
dh_installdocs --remaining-packages
override_dh_auto_clean:
dh_auto_clean
- rm -Rf build-* install-*
+ rm -Rf build-* install-* debian/tmp-dbg
find . -name '*.py[co]' -print0 | xargs -0 rm -f
override_dh_strip:
- dh_strip --dbg-package=python-dbus-dbg
+ dh_strip --dbg-package=python-dbus-dbg -ppython-dbus -ppython-dbus-dbg
+ dh_strip --dbg-package=python3-dbus-dbg -ppython3-dbus -ppython3-dbus-dbg