summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2021-07-20 10:49:55 +0100
committerSimon McVittie <smcv@debian.org>2021-07-20 10:49:55 +0100
commita8def36e2de018a973d8cb70edd8ef50340586ea (patch)
treec03ea586a17c8c5a7797ced744834295adbea4db /Makefile.in
parent823f65de6a9db9f22ec58552e739df56895f859d (diff)
New upstream version 1.2.18
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in38
1 files changed, 24 insertions, 14 deletions
diff --git a/Makefile.in b/Makefile.in
index cd89230..bb64318 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1,7 +1,7 @@
-# Makefile.in generated by automake 1.16.1 from Makefile.am.
+# Makefile.in generated by automake 1.16.3 from Makefile.am.
# @configure_input@
-# Copyright (C) 1994-2018 Free Software Foundation, Inc.
+# Copyright (C) 1994-2020 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
@@ -339,7 +339,7 @@ am__nobase_dist_installed_test_PYTHON_DIST = test/crosstest.py \
test/dbus_test_utils.py
am__py_compile = PYTHON=$(PYTHON) $(SHELL) $(py_compile)
am__pep3147_tweak = \
- sed -e 's|\.py$$||' -e 's|[^/]*$$|&.*.pyc\n&.*.pyo|'
+ sed -e 's|\.py$$||' -e 's|[^/]*$$|__pycache__/&.*.pyc __pycache__/&.*.pyo|'
am__nobase_python_PYTHON_DIST = dbus/bus.py dbus/connection.py \
dbus/_compat.py dbus/_dbus.py dbus/decorators.py \
dbus/exceptions.py dbus/_expat_introspect_parser.py \
@@ -360,8 +360,8 @@ am__recursive_targets = \
AM_RECURSIVE_TARGETS = $(am__recursive_targets:-recursive=) TAGS CTAGS \
cscope check recheck distdir distdir-am dist dist-all \
distcheck
-am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) \
- $(LISP)config.h.in
+am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP) \
+ config.h.in
# Read a list of newline-separated strings from the standard input,
# and print each of them once, without duplicates. Input order is
# *not* preserved.
@@ -536,6 +536,7 @@ am__set_TESTS_bases = \
bases='$(TEST_LOGS)'; \
bases=`for i in $$bases; do echo $$i; done | sed 's/\.log$$//'`; \
bases=`echo $$bases`
+AM_TESTSUITE_SUMMARY_HEADER = ' for $(PACKAGE_STRING)'
RECHECK_LOGS = $(TEST_LOGS)
am__EXEEXT_2 = test/test-client.py test/test-p2p.py \
test/test-signals.py test/test-standalone.py \
@@ -613,6 +614,8 @@ am__relativize = \
DIST_ARCHIVES = $(distdir).tar.gz
GZIP_ENV = --best
DIST_TARGETS = dist-gzip
+# Exists only to be overridden by the user if desired.
+AM_DISTCHECK_DVI_TARGET = dvi
distuninstallcheck_listfiles = find . -type f -print
am__distuninstallcheck_listfiles = $(distuninstallcheck_listfiles) \
| sed 's|^\./|$(prefix)/|' | grep -v '$(infodir)/dir$$'
@@ -767,16 +770,17 @@ top_srcdir = @top_srcdir@
installed_testdir = ${libexecdir}/installed-tests/${PACKAGE_TARNAME}
installed_test_testdir = ${installed_testdir}/test
installed_test_metadir = ${datadir}/installed-tests/${PACKAGE_TARNAME}
+AM_DISTCHECK_CONFIGURE_FLAGS = PYTHON=$(PYTHON)
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = dbus-gmain .
CLEANFILES = test/test-service.log $(NULL) $(noinst_DATA) \
$(installed_test_test_data) $(installed_test_metadata)
# A hack used for the HTML documentation on dbus.freedesktop.org
-EXTRA_DIST = .travis.yml AUTHORS CONTRIBUTING.md COPYING \
- dbus-python.pc.in doc/_static/.gitignore \
- examples/example-async-client.py examples/example-client.py \
- examples/example-service.py examples/example-signal-emitter.py \
+EXTRA_DIST = AUTHORS CONTRIBUTING.md COPYING dbus-python.pc.in \
+ doc/_static/.gitignore examples/example-async-client.py \
+ examples/example-client.py examples/example-service.py \
+ examples/example-signal-emitter.py \
examples/example-signal-recipient.py \
examples/gconf-proxy-client.py \
examples/gconf-proxy-service2.py \
@@ -1484,7 +1488,7 @@ uninstall-nobase_dist_installed_testPYTHON:
for files in "$$py_files" "$$pyc_files" "$$pyo_files"; do \
$(am__uninstall_files_from_dir) || st=$$?; \
done; \
- dir='$(DESTDIR)$(installed_testdir)/__pycache__'; \
+ dir='$(DESTDIR)$(installed_testdir)'; \
echo "$$py_files" | $(am__pep3147_tweak) | $(am__base_list) | \
while read files; do \
$(am__uninstall_files_from_dir) || st=$$?; \
@@ -1526,7 +1530,7 @@ uninstall-nobase_pythonPYTHON:
for files in "$$py_files" "$$pyc_files" "$$pyo_files"; do \
$(am__uninstall_files_from_dir) || st=$$?; \
done; \
- dir='$(DESTDIR)$(pythondir)/__pycache__'; \
+ dir='$(DESTDIR)$(pythondir)'; \
echo "$$py_files" | $(am__pep3147_tweak) | $(am__base_list) | \
while read files; do \
$(am__uninstall_files_from_dir) || st=$$?; \
@@ -1830,7 +1834,7 @@ $(TEST_SUITE_LOG): $(TEST_LOGS)
test x"$$VERBOSE" = x || cat $(TEST_SUITE_LOG); \
fi; \
echo "$${col}$$br$${std}"; \
- echo "$${col}Testsuite summary for $(PACKAGE_STRING)$${std}"; \
+ echo "$${col}Testsuite summary"$(AM_TESTSUITE_SUMMARY_HEADER)"$${std}"; \
echo "$${col}$$br$${std}"; \
create_testsuite_report --maybe-color; \
echo "$$col$$br$$std"; \
@@ -1986,6 +1990,10 @@ dist-xz: distdir
tardir=$(distdir) && $(am__tar) | XZ_OPT=$${XZ_OPT--e} xz -c >$(distdir).tar.xz
$(am__post_remove_distdir)
+dist-zstd: distdir
+ tardir=$(distdir) && $(am__tar) | zstd -c $${ZSTD_CLEVEL-$${ZSTD_OPT--19}} >$(distdir).tar.zst
+ $(am__post_remove_distdir)
+
dist-tarZ: distdir
@echo WARNING: "Support for distribution archives compressed with" \
"legacy program 'compress' is deprecated." >&2
@@ -2028,6 +2036,8 @@ distcheck: dist
eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).shar.gz | unshar ;;\
*.zip*) \
unzip $(distdir).zip ;;\
+ *.tar.zst*) \
+ zstd -dc $(distdir).tar.zst | $(am__untar) ;;\
esac
chmod -R a-w $(distdir)
chmod u+w $(distdir)
@@ -2043,7 +2053,7 @@ distcheck: dist
$(DISTCHECK_CONFIGURE_FLAGS) \
--srcdir=../.. --prefix="$$dc_install_base" \
&& $(MAKE) $(AM_MAKEFLAGS) \
- && $(MAKE) $(AM_MAKEFLAGS) dvi \
+ && $(MAKE) $(AM_MAKEFLAGS) $(AM_DISTCHECK_DVI_TARGET) \
&& $(MAKE) $(AM_MAKEFLAGS) check \
&& $(MAKE) $(AM_MAKEFLAGS) install \
&& $(MAKE) $(AM_MAKEFLAGS) installcheck \
@@ -2295,7 +2305,7 @@ uninstall-am: uninstall-dbusincludeHEADERS \
clean-noinstPROGRAMS clean-pyexecLTLIBRARIES cscope \
cscopelist-am ctags ctags-am dist dist-all dist-bzip2 \
dist-gzip dist-hook dist-lzip dist-shar dist-tarZ dist-xz \
- dist-zip distcheck distclean distclean-compile \
+ dist-zip dist-zstd distcheck distclean distclean-compile \
distclean-generic distclean-hdr distclean-libtool \
distclean-tags distcleancheck distdir distuninstallcheck dvi \
dvi-am html html-am info info-am install install-am \