summaryrefslogtreecommitdiff
path: root/_dbus_bindings
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2015-12-05 15:41:11 +0000
committerSimon McVittie <smcv@debian.org>2015-12-06 10:25:16 +0000
commit9eae0f2693acee05887125a46190e682fa119e78 (patch)
treed7f375b91d995026896c17f1818eda3d46583bc7 /_dbus_bindings
parentf8479140d228d7d5043069a0e966e9d3bf94e341 (diff)
Use AX_COMPILER_FLAGS
Diffstat (limited to '_dbus_bindings')
-rw-r--r--_dbus_bindings/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/_dbus_bindings/Makefile.am b/_dbus_bindings/Makefile.am
index 42c9f91..e0610c9 100644
--- a/_dbus_bindings/Makefile.am
+++ b/_dbus_bindings/Makefile.am
@@ -1,9 +1,18 @@
pyexec_LTLIBRARIES = _dbus_bindings.la
-AM_CPPFLAGS = -I$(top_srcdir)/include $(DBUS_CFLAGS) $(PYTHON_INCLUDES)
-AM_LDFLAGS = -module -avoid-version \
- -export-symbols-regex \(PyInit__\|init_\)dbus_bindings \
- $(NULL)
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ $(DBUS_CFLAGS) \
+ $(PYTHON_INCLUDES) \
+ $(NULL)
+AM_CFLAGS = \
+ $(WARN_CFLAGS) \
+ $(NULL)
+AM_LDFLAGS = \
+ -module -avoid-version \
+ -export-symbols-regex \(PyInit__\|init_\)dbus_bindings \
+ $(WARN_LDFLAGS) \
+ $(NULL)
libadd = $(DBUS_LIBS)