summaryrefslogtreecommitdiff
path: root/_dbus_glib_bindings
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2016-01-20 10:48:19 +0000
committerSimon McVittie <smcv@debian.org>2016-01-20 10:48:19 +0000
commit9567e3eab6672705f7259970e8606f4e7adaf991 (patch)
tree9a21dcebce1553848db9195ce0707b88850850ba /_dbus_glib_bindings
parentb95a7f0f596e3e3d000c3756bb520d28b127d5e1 (diff)
Use non-recursive make for everything except tests
Diffstat (limited to '_dbus_glib_bindings')
-rw-r--r--_dbus_glib_bindings/Makefile.am38
1 files changed, 0 insertions, 38 deletions
diff --git a/_dbus_glib_bindings/Makefile.am b/_dbus_glib_bindings/Makefile.am
deleted file mode 100644
index b4c8715..0000000
--- a/_dbus_glib_bindings/Makefile.am
+++ /dev/null
@@ -1,38 +0,0 @@
-pyexec_LTLIBRARIES = _dbus_glib_bindings.la
-
-AM_CPPFLAGS = \
- -I$(top_srcdir)/include \
- $(DBUS_CFLAGS) \
- $(DBUS_GLIB_CFLAGS) \
- $(PYTHON_INCLUDES) \
- $(NULL)
-AM_CFLAGS = \
- $(WARN_CFLAGS) \
- $(NULL)
-AM_LDFLAGS = \
- -module -avoid-version \
- -export-symbols-regex \(PyInit__\|init_\)dbus_glib_bindings \
- $(WARN_LDFLAGS) \
- $(NULL)
-
-libadd = \
- $(DBUS_LIBS) \
- $(DBUS_GLIB_LIBS) \
- $(NULL)
-
-if WINDOWS
-# Win32 DLLs can't have undefined symbols (so this needs explicit linking
-# against the Python DLL), and Python expects extensions to be *.pyd
-# instead of *.dll
-AM_LDFLAGS += \
- -no-undefined \
- -shrext ".pyd" \
- $(NULL)
-
-libadd += \
- $(PYTHON_LIBS) \
- $(NULL)
-endif
-
-_dbus_glib_bindings_la_LIBADD = $(libadd)
-_dbus_glib_bindings_la_SOURCES = module.c