summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2016-03-02 10:18:43 +0000
committerSimon McVittie <smcv@debian.org>2016-03-02 10:18:43 +0000
commit2b28ed00f9d28626db2a397f011dfd24f724605a (patch)
treeed143c2a9107bfbf1d7ff8413efb81be7adba3fe /debian/control
parente4814ecb095bce5e8ecca502e5016e57c41b05b3 (diff)
Normalize packaging via wrap-and-sort -abst
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control182
1 files changed, 102 insertions, 80 deletions
diff --git a/debian/control b/debian/control
index 2f467aa..356375e 100644
--- a/debian/control
+++ b/debian/control
@@ -2,29 +2,32 @@ Source: dbus-python
Section: devel
Priority: optional
Maintainer: Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>
-Uploaders: Sjoerd Simons <sjoerd@debian.org>,
- Sebastian Dröge <slomo@debian.org>,
- Simon McVittie <smcv@debian.org>,
- Loic Minier <lool@dooz.org>
-Build-Depends: autoconf,
- autoconf-archive,
- automake,
- dbus,
- debhelper (>= 9),
- dh-autoreconf,
- dh-python,
- dpkg-dev (>= 1.16.1),
- python-all-dbg (>= 2.6.6-3~),
- python-all-dev (>= 2.6.6-3~),
- python-gi,
- python3-all-dbg,
- python3-all-dev,
- python3-gi,
- libdbus-1-dev (>= 1.6),
- libdbus-glib-1-dev (>= 0.71),
- xmlto
-Build-Depends-Indep: python-docutils,
- python-epydoc (>= 3.0~beta1)
+Uploaders:
+ Sjoerd Simons <sjoerd@debian.org>,
+ Sebastian Dröge <slomo@debian.org>,
+ Simon McVittie <smcv@debian.org>,
+ Loic Minier <lool@dooz.org>,
+Build-Depends:
+ autoconf,
+ autoconf-archive,
+ automake,
+ dbus,
+ debhelper (>= 9),
+ dh-autoreconf,
+ dh-python,
+ dpkg-dev (>= 1.16.1),
+ libdbus-1-dev (>= 1.6),
+ libdbus-glib-1-dev (>= 0.71),
+ python-all-dbg (>= 2.6.6-3~),
+ python-all-dev (>= 2.6.6-3~),
+ python-gi,
+ python3-all-dbg,
+ python3-all-dev,
+ python3-gi,
+ xmlto,
+Build-Depends-Indep:
+ python-docutils,
+ python-epydoc (>= 3.0~beta1),
Standards-Version: 3.9.7
X-Python-Version: >= 2.6
X-Python3-Version: >= 3.2
@@ -35,17 +38,25 @@ Vcs-Browser: https://anonscm.debian.org/cgit/pkg-utopia/dbus-python.git
Package: python-dbus
Section: python
Architecture: any
-Depends: ${misc:Depends},
- ${python:Depends},
- ${shlibs:Depends},
-Recommends: python-gi
-Suggests: python-dbus-doc, python-dbus-dbg
-Replaces: python2.4-dbus
-Conflicts: python2.4-dbus
-Breaks: gnome-osd (<< 0.12.0),
- gajim (<< 0.11.1),
- python-qt4-dbus (<< 4.8.3-3)
-Provides: ${python:Provides}
+Depends:
+ ${misc:Depends},
+ ${python:Depends},
+ ${shlibs:Depends},
+Recommends:
+ python-gi,
+Suggests:
+ python-dbus-dbg,
+ python-dbus-doc,
+Replaces:
+ python2.4-dbus,
+Conflicts:
+ python2.4-dbus,
+Breaks:
+ gajim (<< 0.11.1),
+ gnome-osd (<< 0.12.0),
+ python-qt4-dbus (<< 4.8.3-3),
+Provides:
+ ${python:Provides},
Description: simple interprocess messaging system (Python interface)
D-Bus is a message bus, used for sending messages between applications.
Conceptually, it fits somewhere in between raw sockets and CORBA in
@@ -55,34 +66,32 @@ Description: simple interprocess messaging system (Python interface)
.
See the dbus description for more information about D-Bus in general.
-Package: python3-dbus
-Section: python
+Package: python-dbus-dbg
+Section: debug
+Priority: extra
Architecture: any
-Depends: ${misc:Depends},
- ${python3:Depends},
- ${shlibs:Depends}
-Recommends: python3-gi
-Suggests: python-dbus-doc, python3-dbus-dbg
-Provides: ${python3:Provides}
-Description: simple interprocess messaging system (Python 3 interface)
- D-Bus is a message bus, used for sending messages between applications.
- Conceptually, it fits somewhere in between raw sockets and CORBA in
- terms of complexity.
- .
- This package provides a Python 3 interface to D-Bus.
- .
- See the dbus description for more information about D-Bus in general.
+Depends:
+ python-dbg,
+ python-dbus (= ${binary:Version}),
+ ${misc:Depends},
+ ${python:Depends},
+ ${shlibs:Depends},
+Description: debug build of the D-Bus Python 2 interface
+ This package provides a version of the python-dbus package built for
+ debugging versions of Python 2, and debug symbols for python-dbus.
Package: python-dbus-dev
Section: python
Architecture: all
Depends:
- ${misc:Depends},
libdbus-1-dev (>= 1.6),
-Breaks: python-dbus (<< 1.0),
- python-dbus-common (<< 1.0)
-Replaces: python-dbus (<< 1.0),
- python-dbus-common (<< 1.0)
+ ${misc:Depends},
+Breaks:
+ python-dbus (<< 1.0),
+ python-dbus-common (<< 1.0),
+Replaces:
+ python-dbus (<< 1.0),
+ python-dbus-common (<< 1.0),
Description: main loop integration development files for python-dbus
D-Bus is a message bus, used for sending messages between applications.
Conceptually, it fits somewhere in between raw sockets and CORBA in
@@ -94,37 +103,50 @@ Description: main loop integration development files for python-dbus
on python-dbus-dev should also build-depend on python-dbus,
python3-dbus, python-dbus-dbg and/or python3-dbus-dbg.
-Package: python-dbus-dbg
-Section: debug
-Priority: extra
+Package: python-dbus-doc
+Section: doc
+Architecture: all
+Depends:
+ ${misc:Depends},
+Suggests:
+ python-dbus | python3-dbus,
+Description: Documentation for the D-Bus Python interface
+ This package provides text and HTML documentation, and examples, for the
+ python-dbus and python3-dbus packages.
+
+Package: python3-dbus
+Section: python
Architecture: any
-Depends: python-dbg,
- python-dbus (= ${binary:Version}),
- ${shlibs:Depends},
- ${misc:Depends},
- ${python:Depends}
-Description: debug build of the D-Bus Python 2 interface
- This package provides a version of the python-dbus package built for
- debugging versions of Python 2, and debug symbols for python-dbus.
+Depends:
+ ${misc:Depends},
+ ${python3:Depends},
+ ${shlibs:Depends},
+Recommends:
+ python3-gi,
+Suggests:
+ python-dbus-doc,
+ python3-dbus-dbg,
+Provides:
+ ${python3:Provides},
+Description: simple interprocess messaging system (Python 3 interface)
+ D-Bus is a message bus, used for sending messages between applications.
+ Conceptually, it fits somewhere in between raw sockets and CORBA in
+ terms of complexity.
+ .
+ This package provides a Python 3 interface to D-Bus.
+ .
+ See the dbus description for more information about D-Bus in general.
Package: python3-dbus-dbg
Section: debug
Priority: extra
Architecture: any
-Depends: python3-dbg,
- python3-dbus (= ${binary:Version}),
- ${shlibs:Depends},
- ${misc:Depends},
- ${python:Depends}
+Depends:
+ python3-dbg,
+ python3-dbus (= ${binary:Version}),
+ ${misc:Depends},
+ ${python:Depends},
+ ${shlibs:Depends},
Description: debug build of the D-Bus Python 3 interface
This package provides a version of the python3-dbus package built for
debugging versions of Python 3, and debug symbols for python3-dbus.
-
-Package: python-dbus-doc
-Section: doc
-Architecture: all
-Depends: ${misc:Depends}
-Suggests: python-dbus | python3-dbus
-Description: Documentation for the D-Bus Python interface
- This package provides text and HTML documentation, and examples, for the
- python-dbus and python3-dbus packages.