summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2018-01-29 13:30:24 +0000
committerSimon McVittie <smcv@debian.org>2018-01-29 13:54:53 +0000
commit30c646bdbbae1a8f7b0738da2e5d09e4fb477a18 (patch)
treece984410f2342efe0cd606ee4ead9a1de641a1e6 /debian
parentd64a1ba7bc5019445584dc4fc4098e31b9be3248 (diff)
Really set PYTHON_LIBS for python2.7-dbg
Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index eceaa48..d5a6950 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,7 +21,7 @@ FLAVOURS := $(patsubst %,%-dbg,$(PYTHON2) $(PYTHON3)) $(PYTHON2) $(PYTHON3)
# -lpython2.7.
override_dh_auto_configure-arch:
set -e; for x in $(FLAVOURS); do \
- if [ "x$x" = x2.7-dbg ]; then \
+ if [ "x$$x" = x2.7-dbg ]; then \
maybe_python_libs="PYTHON_LIBS=-lpython2.7_d"; \
else \
maybe_python_libs=""; \
@@ -30,6 +30,7 @@ override_dh_auto_configure-arch:
--builddirectory=build-$$x \
-- \
PYTHON=/usr/bin/python$$x \
+ $${maybe_python_libs} \
--disable-api-docs \
--disable-html-docs \
--enable-installed-tests \