summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2018-01-29 13:14:40 +0000
committerSimon McVittie <smcv@debian.org>2018-01-29 13:14:40 +0000
commit4f6ed6262cc543ab11dce319d37b07ba3dfe55a1 (patch)
tree51594a9547607a056201363b8a8f58b9573243f3 /debian
parent21f62d83e8c0571149b87c2dbee27302cf7a66b5 (diff)
Add a workaround for AX_PYTHON_DEVEL with python2.7-dbg
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e23df0c..9ea85c4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,8 +15,17 @@ FLAVOURS := $(patsubst %,%-dbg,$(PYTHON2) $(PYTHON3)) $(PYTHON2) $(PYTHON3)
%:
dh $@ --with python2,python3 --buildsystem=autoconf
+# The special case for 2.7-dbg is a workaround. Python 2 doesn't have the
+# LDVERSION sysconfig variable, which would give AX_PYTHON_DEVEL the
+# information it needs to know that it should link -lpython2.7_d and not
+# -lpython2.7.
override_dh_auto_configure-arch:
set -e && for x in $(FLAVOURS); do \
+ if [ "x$x" = x2.7-dbg ]; then \
+ maybe_python_libs="PYTHON_LIBS=-lpython2.7_d"; \
+ else \
+ maybe_python_libs=""; \
+ fi; \
dh_auto_configure \
--builddirectory=build-$$x \
-- \