summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2022-09-06 18:41:07 +0100
committerSimon McVittie <smcv@debian.org>2022-09-06 18:41:07 +0100
commit4837813dc5c950ea6bacba5c651d9bdae9b0a93a (patch)
treed588031b20ed6cc6f81a574bf7dd42a647804d58 /pyproject.toml
parentd0a421a79fd9056e4e8bf4d8fabbf04994114050 (diff)
New upstream version 1.3.0
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..3949d8f
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,50 @@
+# Copyright 2022 Collabora Ltd.
+# SPDX-License-Identifier: MIT
+
+[build-system]
+build-backend = 'mesonpy'
+requires = [
+ 'meson-python>=0.8.1',
+ 'meson>=0.60.0',
+ 'ninja',
+ 'patchelf',
+ 'setuptools',
+ 'wheel',
+]
+
+[project]
+name = 'dbus-python'
+license = { text = 'Expat (MIT/X11)' }
+description = 'Python bindings for libdbus'
+maintainers = [
+ { name = 'The D-Bus maintainers', email = 'dbus@lists.freedesktop.org' },
+]
+requires-python = '>=3.7'
+readme = { file = 'README', content-type = 'text/x-rst' }
+keywords = ['dbus', 'D-Bus']
+classifiers = [
+ 'Development Status :: 7 - Inactive',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: C',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Topic :: Software Development :: Object Brokering',
+]
+dynamic = [
+ 'version'
+]
+
+[project.optional-dependencies]
+doc = [
+ 'sphinx',
+ 'sphinx_rtd_theme',
+]
+test = [
+ 'tap.py',
+]
+
+[project.urls]
+homepage = 'http://www.freedesktop.org/wiki/Software/DBusBindings/#python'
+download = 'http://dbus.freedesktop.org/releases/dbus-python/'
+source = 'https://gitlab.freedesktop.org/dbus/dbus-python/'
+tracker = 'https://gitlab.freedesktop.org/dbus/dbus-python/-/issues'