summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2015-12-05 15:41:11 +0000
committerSimon McVittie <smcv@debian.org>2015-12-06 10:25:16 +0000
commit9eae0f2693acee05887125a46190e682fa119e78 (patch)
treed7f375b91d995026896c17f1818eda3d46583bc7 /test
parentf8479140d228d7d5043069a0e966e9d3bf94e341 (diff)
Use AX_COMPILER_FLAGS
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am26
1 files changed, 19 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f4bc6e5..a37b57d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -26,12 +26,24 @@ pyexec_LTLIBRARIES = dbus_py_test.la
install:
@echo "Not installing anything from test/"
-dbus_py_test_la_CPPFLAGS = -I$(top_srcdir)/include $(DBUS_CFLAGS) \
- $(PYTHON_INCLUDES)
-dbus_py_test_la_LDFLAGS = -module -avoid-version \
- $(DBUS_LIBS)
-dbus_py_test_la_SOURCES = dbus_py_test.c \
- $(top_srcdir)/include/dbus-python.h
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ $(DBUS_CFLAGS) \
+ $(PYTHON_INCLUDES) \
+ $(NULL)
+AM_CFLAGS = \
+ $(WARN_CFLAGS) \
+ $(NULL)
+AM_LDFLAGS = \
+ -module \
+ -avoid-version \
+ $(WARN_LDFLAGS) \
+ $(NULL)
+
+dbus_py_test_la_LIBADD = $(DBUS_LIBS)
+dbus_py_test_la_SOURCES = \
+ dbus_py_test.c \
+ $(top_srcdir)/include/dbus-python.h
AM_TESTS_ENVIRONMENT = \
export DBUS_TOP_SRCDIR="$(abs_top_srcdir)"; \
@@ -47,7 +59,7 @@ check_PROGRAMS = test-import-repeatedly
test_import_repeatedly_SOURCES = import-repeatedly.c
test_import_repeatedly_CPPFLAGS = $(PYTHON_INCLUDES)
-test_import_repeatedly_LDFLAGS = $(PYTHON_LIBS)
+test_import_repeatedly_LDADD = $(PYTHON_LIBS)
cross-test-server:
$(AM_TESTS_ENVIRONMENT) $(PYTHON) $(top_srcdir)/test/cross-test-server.py