summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e23df0c..9ea85c4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,8 +15,17 @@ FLAVOURS := $(patsubst %,%-dbg,$(PYTHON2) $(PYTHON3)) $(PYTHON2) $(PYTHON3)
%:
dh $@ --with python2,python3 --buildsystem=autoconf
+# The special case for 2.7-dbg is a workaround. Python 2 doesn't have the
+# LDVERSION sysconfig variable, which would give AX_PYTHON_DEVEL the
+# information it needs to know that it should link -lpython2.7_d and not
+# -lpython2.7.
override_dh_auto_configure-arch:
set -e && for x in $(FLAVOURS); do \
+ if [ "x$x" = x2.7-dbg ]; then \
+ maybe_python_libs="PYTHON_LIBS=-lpython2.7_d"; \
+ else \
+ maybe_python_libs=""; \
+ fi; \
dh_auto_configure \
--builddirectory=build-$$x \
-- \