summaryrefslogtreecommitdiff
path: root/subprojects/dbus-gmain/.editorconfig
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/dbus-gmain/.editorconfig')
-rw-r--r--subprojects/dbus-gmain/.editorconfig28
1 files changed, 28 insertions, 0 deletions
diff --git a/subprojects/dbus-gmain/.editorconfig b/subprojects/dbus-gmain/.editorconfig
new file mode 100644
index 0000000..05bbe50
--- /dev/null
+++ b/subprojects/dbus-gmain/.editorconfig
@@ -0,0 +1,28 @@
+# For format see editorconfig.org
+# Copyright 2022 Collabora Ltd.
+# SPDX-License-Identifier: MIT
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+tab_width = 8
+
+[{*.py,*.sh,*.yml,meson.build}]
+indent_size = 4
+indent_style = space
+
+[{*.c,*.h}]
+indent_size = 2
+indent_style = space
+
+[Makefile.am]
+indent_size = 8
+indent_style = tab
+
+[*.md]
+indent_size = 4
+indent_style = space
+tab_width = 4