summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-08-03 11:43:59 +0100
committerColin Watson <cjwatson@debian.org>2019-08-03 11:43:59 +0100
commitfe64f47fd65a78119e9f45a24ffe244a7e2028cc (patch)
tree7a28d2ad7257979c04b33e6e645365171a00efa3
parent274f988d33f14b7148621643f1dd553582dc47e8 (diff)
Drop Python 2 support
-rw-r--r--Makefile13
-rw-r--r--debian/changelog1
-rw-r--r--debian/control15
-rwxr-xr-xdebian/rules3
4 files changed, 4 insertions, 28 deletions
diff --git a/Makefile b/Makefile
index 37385f21..5b840531 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ clean:
# Does not attempt to install documentation, as that can be fairly system
# specific.
-install: install-utils install-python2 install-python3 install-rest
+install: install-utils install-python3 install-rest
# Anything that goes in the debconf-utils package.
install-utils:
@@ -35,17 +35,6 @@ install-i18n:
PERL := perl
PERL_VENDORLIB := $(shell $(PERL) -MConfig -e 'print $$Config{vendorlib}')
-# This would probably be easier if we used setup.py ...
-PYTHON2_SUPPORTED := $(shell pyversions -s)
-PYTHON_SITEDIR = $(prefix)/usr/lib/$(1)/$(if $(filter 2.0 2.1 2.2 2.3 2.4 2.5,$(patsubst python%,%,$(1))),site-packages,dist-packages)
-
-# The Python 2 package.
-install-python2:
- set -e; for dir in $(foreach python,$(PYTHON2_SUPPORTED),$(call PYTHON_SITEDIR,$(python))); do \
- install -d $$dir; \
- install -m 0644 debconf.py $$dir/; \
- done
-
# The Python 3 package.
install-python3:
install -d $(prefix)/usr/lib/python3/dist-packages
diff --git a/debian/changelog b/debian/changelog
index c6e76121..2fbd1ae9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ debconf (1.5.73) UNRELEASED; urgency=medium
* Use debhelper-compat instead of debian/compat.
* Remove ancient X-Python-Version field.
+ * Drop Python 2 support.
-- Colin Watson <cjwatson@debian.org> Sat, 03 Aug 2019 11:37:30 +0100
diff --git a/debian/control b/debian/control
index 8910aa5a..f031e9d2 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Debconf Developers <debconf-devel@lists.alioth.debian.org>
Uploaders: Colin Watson <cjwatson@debian.org>
Standards-Version: 4.0.0
-Build-Depends-Indep: perl (>= 5.10.0-16), python (>= 2.6.6-3~), python3 (>= 3.1.2-8), gettext (>= 0.13), libintl-perl
+Build-Depends-Indep: perl (>= 5.10.0-16), python3 (>= 3.1.2-8), gettext (>= 0.13), libintl-perl
Build-Depends: debhelper-compat (= 9), dh-exec, dh-python, po-debconf, po4a (>= 0.23)
Vcs-Git: https://salsa.debian.org/pkg-debconf/debconf.git
Vcs-Browser: https://salsa.debian.org/pkg-debconf/debconf
@@ -60,19 +60,6 @@ Architecture: all
Description: debconf utilities
This package contains some small utilities for debconf developers.
-Package: python-debconf
-Section: python
-Depends: debconf (= ${binary:Version}), ${misc:Depends}, ${python:Depends}
-Breaks: debconf (<< 1.5.64)
-Replaces: debconf (<< 1.5.64)
-Architecture: all
-Description: interact with debconf from Python 2
- Debconf is a configuration management system for debian packages. Packages
- use Debconf to ask questions when they are installed.
- .
- This package provides a debconf module to allow Python 2 programs to
- interact with a debconf frontend.
-
Package: python3-debconf
Section: python
Depends: debconf (= ${binary:Version}), ${misc:Depends}, ${python3:Depends}
diff --git a/debian/rules b/debian/rules
index 05985d2a..3d7448b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,12 +5,11 @@
export PERL5LIB=.
%:
- dh $@ --with python2,python3
+ dh $@ --with python3
override_dh_auto_install:
$(MAKE) prefix=`pwd`/debian/debconf-utils install-utils
$(MAKE) prefix=`pwd`/debian/debconf-i18n install-i18n
- $(MAKE) prefix=`pwd`/debian/python-debconf install-python2
$(MAKE) prefix=`pwd`/debian/python3-debconf install-python3
$(MAKE) prefix=`pwd`/debian/debconf install-rest