summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-04-12 03:04:35 +0000
committerjoey <joey>2002-04-12 03:04:35 +0000
commit29fd2dcb7d861e78f8b5855abd06364e8d60c2ed (patch)
treeab18887fe7bba32e72f842d5b685181df239c93d
parentea383ca972213bdda50226c536e3224a361904b8 (diff)
r518: * dh_movefiles has long been a sore point in debhelper. Inherited
from debstd, its interface and implementation suck, and I have maintained it while never really deigning to use it. Now there is a remplacment: dh_install, which ... - copies files, doesn't move them. Closes: #75360, #82649 - doesn't have that whole annoying debian/package.files vs. debian/files mess, as it uses debian/install. - supports copying empty subdirs. Closes: #133037 - doesn't use tar, thus no error reproting problems. Closes: #112538 - files are listed relative to the pwd, debian/tmp need not be used at all, so no globbing issues. Closes: #100404 - supports -X. Closes: #116902 - the whole concept of moving files out of a directory is gone, so this bug doesn't really apply. Closes: #120026 - This is exactly what Bill Allombert asked for in #117383, even though I designed it seemingly independantly. Thank you Bill! Closes: #117383 * Made debhelper's debian/rules a lot simpler by means of the above. * Updated example rules file to use dh_install. Also some reordering and other minor changes. * dh_movefiles is lightly deprecated, and when you run into its bugs and bad design, you are incouraged to just use dh_install instead. * dh_fixperms: in v4 only, make all files in bin/ dirs +x. Closes: #119039 * dh_fixperms: in v4 only, make all files in etc/init.d executable (of course there's -X ..) * dh_link: in v4 only, finds existing, non-policy-conformant symlinks and corrects them. This has the side effect of making dh_link idempotent. * Added a -h/--help option. This seems very obvious, but it never occured to me before.. * use v4 for building debhelper itself * v4 mode is done, you may now use it without fear of it changing. (This idea of this upload is to get v4 into woody so people won't run into many issues backporting from sarge to woody later on. Packages targeted for woody should continue to use whatever compatability level they are using.)
-rw-r--r--Debian/Debhelper/Dh_Getopt.pm14
-rw-r--r--Debian/Debhelper/Dh_Lib.pm19
-rw-r--r--debhelper.pod26
-rw-r--r--debian/changelog39
-rw-r--r--debian/compat2
-rw-r--r--debian/copyright2
-rwxr-xr-xdebian/rules32
-rwxr-xr-xdh_fixperms22
-rwxr-xr-xdh_install146
-rwxr-xr-xdh_link27
-rwxr-xr-xdh_movefiles3
-rw-r--r--doc/TODO21
-rwxr-xr-xexamples/rules13
-rwxr-xr-xexamples/rules.indep11
-rwxr-xr-xexamples/rules.multi24
-rwxr-xr-xexamples/rules.multi211
16 files changed, 321 insertions, 91 deletions
diff --git a/Debian/Debhelper/Dh_Getopt.pm b/Debian/Debhelper/Dh_Getopt.pm
index 191227da..81d20618 100644
--- a/Debian/Debhelper/Dh_Getopt.pm
+++ b/Debian/Debhelper/Dh_Getopt.pm
@@ -2,7 +2,7 @@
#
# Debhelper option processing library.
#
-# Joey Hess GPL copyright 1998.
+# Joey Hess GPL copyright 1998-2002
package Debian::Debhelper::Dh_Getopt;
use strict;
@@ -16,6 +16,14 @@ use Exporter;
my (%options, %exclude_package);
+sub showhelp {
+ my $prog=basename($0);
+ print "Usage: $prog [options]\n\n";
+ print " $prog is a part of debhelper. See debhelper(1)\n";
+ print " and $prog(1) for complete usage instructions.\n";
+ exit(1);
+}
+
# Passed an option name and an option value, adds packages to the list
# of packages. We need this so the list will be built up in the right
# order.
@@ -129,6 +137,10 @@ sub parseopts {
"priority=i" => \$options{PRIORITY},
"flavor=s" => \$options{FLAVOR},
+
+ "autodest" => \$options{AUTODEST},
+
+ "h|help" => \&showhelp,
"<>" => \&NonOption,
);
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 81ef6cae..0aa883b1 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -422,17 +422,19 @@ sub addsubstvar {
}
}
-# Reads in the specified file, one word at a time, and returns an array of
-# the result. If a value is passed in as the second parameter, then glob
+# Reads in the specified file, one line at a time. splits on words,
+# and returns an array of arrays of the contents.
+# If a value is passed in as the second parameter, then glob
# expansion is done in the directory specified by the parameter ("." is
# frequently a good choice).
-sub filearray {
+sub filedoublearray {
my $file=shift;
my $globdir=shift;
my @ret;
open (DH_FARRAY_IN, $file) || error("cannot read $file: $1");
while (<DH_FARRAY_IN>) {
+ my @line;
# Only do glob expansion in v3 mode.
#
# The tricky bit is that the glob expansion is done
@@ -441,18 +443,25 @@ sub filearray {
if (defined $globdir && ! compat(2)) {
for (map { glob "$globdir/$_" } split) {
s#^$globdir/##;
- push @ret, $_;
+ push @line, $_;
}
}
else {
- push @ret, split;
+ @line = split;
}
+ push @ret, [@line];
}
close DH_FARRAY_IN;
return @ret;
}
+# Reads in the specified file, one word at a time, and returns an array of
+# the result. Can do globbing as does filedoublearray.
+sub filearray {
+ return map { @$_ } filedoublearray(@_);
+}
+
# Passed a filename, returns true if -X says that file should be excluded.
sub excludefile {
my $filename = shift;
diff --git a/debhelper.pod b/debhelper.pod
index df822163..d8efb529 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -185,11 +185,13 @@ the set command):
=head2 Automatic generation of miscellaneous dependencies.
Some debhelper commands may make the generated package need to depend on
-some other packages. For example, if you use L<dh_installdebconf(1)>, you'r
+some other packages. For example, if you use L<dh_installdebconf(1)>, your
package will generally need to depend on debconf. Or if you use
L<dh_installxfonts(1)>, your package will generally need to depend on a
particular version of xutils. Keeping track of these miscellaneous
-dependencies can be annoying, so debhelper offers a way to automate it.
+dependencies can be annoying since they are dependant on how debhelper does
+things, so debhelper offers a way to automate it.
+
All commands of this type, besides documenting what dependencies may be
needed on their man pages, will automatically generate a substvar called
${misc:Depends}. If you put that token into your debian/control file, it
@@ -223,9 +225,9 @@ introduced. You tell debhelper which compatability level it should use, and
it modifies its behavior in various ways.
You tell debhelper what compatability level to use by writing a number to
-debian/compat. For example, to turn on V3 mode:
+debian/compat. For example, to turn on V4 mode:
- % echo 3 > debian/compat
+ % echo 4 > debian/compat
These are the available compatablity levels:
@@ -246,8 +248,7 @@ as the package tree directory for every package that is built.
=item V3
-This is the reccommended mode of operation. It does everything V2 does,
-plus:
+This mode works like V2, with the following additions:
=over 8
@@ -268,8 +269,8 @@ Every file in etc/ is automatically flagged as a conffile by dh_installdeb.
=item V4
-This mode is still under development, and its behavior may change at any
-time. Currently, it does everything V3 does, plus:
+This is the reccommended mode of operation. It does everything V3 does,
+plus:
=over 8
@@ -283,6 +284,15 @@ the generated dependancy line in the shlibs file.
dh_installinit uses the new invoke-rc.d program in its generated maintainer
scripts. (This may later be rolled back into V3).
+=item -
+
+dh_fixperms will make all files in bin/ directories and in etc/init.d
+executable.
+
+=item -
+
+dh_link will correct existing links to conform with policy.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index abb70c7e..342f4c76 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,42 @@
+debhelper (4.0.0) unstable; urgency=low
+
+ * dh_movefiles has long been a sore point in debhelper. Inherited
+ from debstd, its interface and implementation suck, and I have maintained
+ it while never really deigning to use it. Now there is a remplacment:
+ dh_install, which ...
+ - copies files, doesn't move them. Closes: #75360, #82649
+ - doesn't have that whole annoying debian/package.files vs. debian/files
+ mess, as it uses debian/install.
+ - supports copying empty subdirs. Closes: #133037
+ - doesn't use tar, thus no error reproting problems. Closes: #112538
+ - files are listed relative to the pwd, debian/tmp need not be used at
+ all, so no globbing issues. Closes: #100404
+ - supports -X. Closes: #116902
+ - the whole concept of moving files out of a directory is gone, so this
+ bug doesn't really apply. Closes: #120026
+ - This is exactly what Bill Allombert asked for in #117383, even though I
+ designed it seemingly independantly. Thank you Bill! Closes: #117383
+ * Made debhelper's debian/rules a lot simpler by means of the above.
+ * Updated example rules file to use dh_install. Also some reordering and
+ other minor changes.
+ * dh_movefiles is lightly deprecated, and when you run into its bugs and
+ bad design, you are incouraged to just use dh_install instead.
+ * dh_fixperms: in v4 only, make all files in bin/ dirs +x. Closes: #119039
+ * dh_fixperms: in v4 only, make all files in etc/init.d executable (of
+ course there's -X ..)
+ * dh_link: in v4 only, finds existing, non-policy-conformant symlinks
+ and corrects them. This has the side effect of making dh_link idempotent.
+ * Added a -h/--help option. This seems very obvious, but it never occured to
+ me before..
+ * use v4 for building debhelper itself
+ * v4 mode is done, you may now use it without fear of it changing.
+ (This idea of this upload is to get v4 into woody so people won't run into
+ many issues backporting from sarge to woody later on. Packages targeted
+ for woody should continue to use whatever compatability level they are
+ using.)
+
+ -- Joey Hess <joeyh@debian.org> Tue, 11 Apr 2002 17:28:57 -0400
+
debhelper (3.4.14) unstable; urgency=low
* Fixed an uninitialized value warning, Closes: #141729
diff --git a/debian/compat b/debian/compat
index 00750edc..b8626c4c 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-3
+4
diff --git a/debian/copyright b/debian/copyright
index 76867829..b8412001 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Debhelper is written by and copyright 1997-2000 Joey Hess <joeyh@debian.org>.
+Debhelper is written by and copyright 1997-2002 Joey Hess <joeyh@debian.org>.
Increasinly miniscule parts of the code (and certainly my inspiration from the
whole thing) came from debmake, by Christoph Lameter <clameter@debian.org>.
diff --git a/debian/rules b/debian/rules
index 363c8c81..b2d030f7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
# I run the most current ones.
#
# This is _not_ a good example of a debhelper rules file, but I didn't need
-# to tell you that; just see the 25 lines of inlined perl below..
+# to tell you that; just see the chunk of inlined perl below..
# See examples/ for some good examples.
# Ensure that builds are self-hosting, which means I have to use the .pm
@@ -19,9 +19,6 @@ VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Ver
PERLLIBDIR=$(shell perl -MConfig -e 'print $$Config{vendorlib}')
-# Debug
-#export DH_VERBOSE=1
-
build: test build-stamp
build-stamp:
# Generate the main man page. All the perl cruft is to get a list
@@ -46,12 +43,15 @@ build-stamp:
# Turn all executables into man pages.
find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
-exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
+ printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
+ Debian/Debhelper/Dh_Version.pm
+
touch build-stamp
clean:
./dh_testdir
./dh_testroot
- -./dh_clean *.1 *-stamp
+ -./dh_clean *.1 *-stamp Debian/Debhelper/Dh_Version.pm
test: test-stamp
test-stamp:
@@ -69,24 +69,12 @@ binary-indep: build
./dh_testdir
./dh_testroot
./dh_clean -k
- ./dh_installdirs usr/bin usr/share/debhelper \
- $(PERLLIBDIR)/Debian/Debhelper
-
- printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
- debian/debhelper/$(PERLLIBDIR)/Debian/Debhelper/Dh_Version.pm
-
- find . -perm +111 -maxdepth 1 -type f -not -name "*.pl" \
- -exec install -p {} debian/debhelper/usr/bin \;
- cp -a Debian/Debhelper/*.pm \
- debian/debhelper/$(PERLLIBDIR)/Debian/Debhelper/
- cp -a autoscripts debian/debhelper/usr/share/debhelper
- rm -rf debian/debhelper/usr/share/debhelper/autoscripts/CVS
-
- ./dh_installdocs `find doc -type f | grep -v CVS`
- ./dh_installexamples `find examples -type f | grep -v CVS`
- ./dh_installmenu
+ ./dh_install -X .1 dh_* usr/bin
+ ./dh_install Debian/Debhelper/*.pm $(PERLLIBDIR)/Debian/Debhelper/
+ ./dh_install autoscripts usr/share/debhelper
+ ./dh_installdocs doc
+ ./dh_installexamples examples/*
./dh_installman *.1
- ./dh_installinfo
./dh_installchangelogs
./dh_shlibdeps
./dh_link
diff --git a/dh_fixperms b/dh_fixperms
index 6b58bab7..145d7361 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -23,7 +23,8 @@ dh_fixperms makes all files in usr/share/doc in the package build directory
(excluding files in the examples/ directory) be mode 644. It also changes
the permissions of all man pages to mode 644. It makes all files be owned by
root, and it removes group and other write permission from all files.
-It removes execute permissions from any libraries that have it set. Finally,
+It removes execute permissions from any libraries that have it set. It makes
+all files in bin/ directories and etc/init.d executable (v4 only). Finally,
it removes the setuid and setgid bits from all files in the package.
=head1 OPTIONS
@@ -58,15 +59,26 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Fix up premissions in usr/share/doc, setting everything to not
# executable by default, but leave examples directories alone.
- complex_doit("find $tmp/usr/share/doc $tmp/usr/doc -type f $find_options ! -regex '.*/examples/.*' -print0",
- "2>/dev/null | xargs -0r chmod 644");
- complex_doit("find $tmp/usr/share/doc $tmp/usr/doc -type d $find_options -print0",
- "2>/dev/null | xargs -0r chmod 755");
+ complex_doit("find $tmp/usr/share/doc $tmp/usr/doc -type f $find_options ! -regex '.*/examples/.*' -print0 2>/dev/null",
+ "| xargs -0r chmod 644");
+ complex_doit("find $tmp/usr/share/doc $tmp/usr/doc -type d $find_options -print0 2>/dev/null",
+ "| xargs -0r chmod 755");
# Executable man pages are a bad thing..
complex_doit("find $tmp/usr/share/man $tmp/usr/man/ $tmp/usr/X11*/man/ -type f",
"$find_options -print0 2>/dev/null | xargs -0r chmod 644");
+ # v4 only
+ if (! compat(3)) {
+ # Programs in the bin and init.d dirs should be executable..
+ for my $dir (qw{usr/bin bin usr/sbin sbin etc/init.d}) {
+ if (-d "$tmp/$dir") {
+ complex_doit("find $tmp/$dir -type f $find_options -print0 2>/dev/null",
+ "| xargs -0r chmod +x");
+ }
+ }
+ }
+
# ..and so are executable shared and static libraries
# (and .la files from libtool)
complex_doit("find $tmp -perm -5 -type f",
diff --git a/dh_install b/dh_install
new file mode 100755
index 00000000..b3dab4c1
--- /dev/null
+++ b/dh_install
@@ -0,0 +1,146 @@
+#!/usr/bin/perl -w
+
+=head1 NAME
+
+dh_install - install files into package build directories
+
+=cut
+
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+B<dh_install> [B<-X>I<item>] [S<I<debhelper options>>] [S<I<file [...] dest>>]
+
+=head1 DESCRIPTION
+
+dh_install is a debhelper program that handles installing files into package
+build directories. There are many dh_install* commands that handle installing
+specific types of files such as documentation, examples, man pages, and so on,
+and they should be used when possible as they often have extra intelligence for
+those particular tasks. dh_install, then, is useful for installing everything
+else, for which no particular intelligence is needed. It is a replacement for
+the old dh_movefiles command.
+
+Files named debian/package.install list the files to install into each
+package and where they should be installed to. The format is a set of
+lines, where each line lists a file or files to install, and at the end of
+the line tells the directory it should be installed in. The name of the
+files (or directories) to install should be given relative to the current
+directory, while the installation directory is given relative to the
+package build directory. You may use wildcards in the names of the files to
+install.
+
+This program may be used in one of two ways. If you just have a file or two
+that the upstream Makefile does not install for you, you can run dh_install
+on them to move them into place. On the other hand, maybe you have a large
+package that builds multiple binary packages. You can use the upstream Makefile
+to install it all into debian/tmp, and then use dh_install to copy
+directories and files from there into the proper package build directories.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-Xitem>, B<--exclude=item>
+
+Exclude files that contain "item" anywhere in their filename from
+being installed.
+
+=item B<--autodest>
+
+Guess as the destination directory to install things to. If this is
+specified, you should not list destination directories in
+debian/package.install files or on the command line. Instead, dh_install
+will guess as follows:
+
+Strip off debian/tmp from the front of the filename, of it is present, and
+install into the dirname of the filename. So if the filename is
+debian/tmp/usr/bin, then that directory will be copied to
+debian/package/usr/. If the filename is debian/tmp/etc/passwd, it will be
+copied to debian/package/etc/.
+
+Note that if you list only a filename on a line by itself in a
+debian/package.install file, with no explicit destination, then dh_install
+will automatically guess the destination even if this flag is not set.
+
+=item I<file [...] dest>
+
+Lists files (or directories) to install and where to install them to.
+The files will be installed into the first package dh_install acts on.
+
+=back
+
+=cut
+
+init();
+
+my $ret=0;
+
+foreach my $package (@{$dh{DOPACKAGES}}) {
+ my $tmp=tmpdir($package);
+ my $file=pkgfile($package,"install");
+
+ my @install;
+ if ($file) {
+ @install=filedoublearray($file, ".");
+ }
+
+ if (($package eq $dh{FIRSTPACKAGE} || $dh{PARAMS_ALL}) && @ARGV) {
+ push @install, [@ARGV];
+ }
+
+ # Support for -X flag.
+ my $exclude = '';
+ if ($dh{EXCLUDE_FIND}) {
+ $exclude = ' -and ! \( '.$dh{EXCLUDE_FIND}.' \)';
+ }
+
+ foreach my $set (@install) {
+ my $dest;
+
+ if (! defined $dh{AUTODEST} && @$set > 1) {
+ $dest=pop @$set;
+ }
+
+ foreach my $src (@$set) {
+ next if excludefile($src);
+
+ if (! defined $dest) {
+ # Guess at destination directory.
+ $dest=$src;
+ $dest=~s/^(.*\/)?debian\/tmp//;
+ $dest=dirname($dest);
+ }
+
+ # Make sure the destination directory exists.
+ if (! -e "$tmp/$dest") {
+ doit("install","-d","$tmp/$dest");
+ }
+
+ if (-d $src && $exclude) {
+ my ($dir_basename) = basename($src);
+ # Pity there's no cp --exclude ..
+ my $pwd=`pwd`;
+ chomp $pwd;
+ complex_doit("cd $src/.. && find $dir_basename -type f$exclude -exec cp --parents -dp {} $pwd/$tmp/$dest/ \\;");
+ }
+ else {
+ doit("cp", "-a", $src, "$tmp/$dest/");
+ }
+ }
+ }
+}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_link b/dh_link
index 41754f5c..5c2a5693 100755
--- a/dh_link
+++ b/dh_link
@@ -7,6 +7,7 @@ dh_link - create symlinks in package build directories
=cut
use strict;
+use File::Find;
use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
@@ -41,6 +42,9 @@ when policy says they should be absolute, and relative links with as short
a path as possible. It will also create any subdirectories it needs to to put
the symlinks in.
+dh_link also scans the package build tree for existing symlinks which do not
+conform to debian policy, and corrects them (v4 only).
+
=head1 OPTIONS
=over 4
@@ -98,6 +102,29 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
error("parameters list a link without a destination.");
}
+ # v4 only
+ if (! compat(3)) {
+ # Scan for existing links and add them to @links, so they
+ # are recreated policy conformant.
+ find(
+ sub {
+ return unless -l;
+ my $dir=$File::Find::dir;
+ $dir=~s/^\Q$tmp\E//;
+ my $target = readlink($_);
+ if ($target=~/^\//) {
+ push @links, $target;
+ }
+ else {
+ push @links, "$dir/$target";
+ }
+ push @links, "$dir/$_";
+ doit("rm","-f",$_);
+
+ },
+ $tmp);
+ }
+
while (@links) {
my $dest=pop @links;
my $src=pop @links;
diff --git a/dh_movefiles b/dh_movefiles
index 499baf6d..6a33cc90 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -26,6 +26,9 @@ also list directory names, and the whole directory will be moved. If you
prefer, you can list the files to move on the command line and this will
apply to the first package dh_movefiles is told to act on.
+Note: dh_install is a much better program that can do everything this one can,
+and more.
+
=head1 OPTIONS
=over 4
diff --git a/doc/TODO b/doc/TODO
index 76113ce2..13a630c0 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -30,16 +30,6 @@ Wishlist items:
This needs more thought.
-* All debhelper programs should be checked that they output files with the
- correct permissions no matter what the umask is set to. Currently, only
- those programs that run after dh_fixperms have been so checked. (Checking
- the rest is low priority, since dh_fixperms fixes any incorrect permissions
- they might have; still it would be nice to check them too, just to make
- debhelper more flexible.) One easy fix is to add umask 022 to dh_lib,
- however, there may be unforeseen ramifications of such a change.
-* All programs should also make sure the files they install are owned by
- root.root. Situation is currently the same as with permissions above, plus
- dh_installchangelogs is fixed.
* Support use of environment variables in data taken from user, ie, in
debian/dirs. The problem with doing this is that we really want to allow
any filenames in that input, even those that look like environment
@@ -54,16 +44,6 @@ Wishlist items:
substitutions. OTOH, maybe it's better if people just sed
postinst.in before debhelper gets it's hands on it... (#25235)
-v4:
-
-See debhelper's man page for what's implemented so far.
-
-These items are planned:
-
-* Maybe make dh_fixperms make all files in bin/ dirs +x. (#119039)
-* Make dh_link find existing, non-policy-comformant symlinks, and correct
- them.
-
Deprecated:
* DH_COMPAT 1. Can be removed once all packages are seen to be using 2 or
@@ -79,3 +59,4 @@ Deprecated:
* dh_installxaw. xaw replacments are dying, nothing uses it validly (bugs
filed on the few packages that use it by accident). Remove as soon as
nothing uses it, or by april 2002.
+* dh_movefiles. I won't hold my breath.
diff --git a/examples/rules b/examples/rules
index 1e57eab5..26c0481f 100755
--- a/examples/rules
+++ b/examples/rules
@@ -42,20 +42,21 @@ binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
-# dh_installdebconf
+ dh_installchangelogs
dh_installdocs
dh_installexamples
- dh_installmenu
+# dh_install
+# dh_installmenu
+# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
- dh_installcron
- dh_installman
- dh_installinfo
+# dh_installcron
+# dh_installinfo
# dh_undocumented
- dh_installchangelogs
+ dh_installman
dh_link
dh_strip
dh_compress
diff --git a/examples/rules.indep b/examples/rules.indep
index aa5a9701..6a01a3eb 100755
--- a/examples/rules.indep
+++ b/examples/rules.indep
@@ -40,20 +40,21 @@ install: build
binary-indep: build install
dh_testdir
dh_testroot
-# dh_installdebconf
+ dh_installchangelogs
dh_installdocs
dh_installexamples
- dh_installmenu
+# dh_installmenu
+# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
- dh_installcron
+# dh_installcron
# dh_installman
- dh_installinfo
+# dh_installinfo
# dh_undocumented
- dh_installchangelogs
+ dh_installman
dh_link
dh_compress
dh_fixperms
diff --git a/examples/rules.multi b/examples/rules.multi
index 8e1e8927..9e3a448b 100755
--- a/examples/rules.multi
+++ b/examples/rules.multi
@@ -39,26 +39,26 @@ install: build
# Add here commands to install the package into debian/tmp.
#$(MAKE) prefix=`pwd`/debian/tmp/usr install
- dh_movefiles
+ dh_install
# Build architecture-independent files here.
binary-indep: build install
dh_testdir -i
dh_testroot -i
-# dh_installdebconf -i
+ dh_installchangelogs -i
dh_installdocs -i
dh_installexamples -i
- dh_installmenu -i
+# dh_installmenu -i
+# dh_installdebconf -i
# dh_installlogrotate -i
# dh_installemacsen -i
# dh_installpam -i
# dh_installmime -i
# dh_installinit -i
- dh_installcron -i
- dh_installman -i
- dh_installinfo -i
+# dh_installcron -i
+# dh_installinfo -i
# dh_undocumented -i
- dh_installchangelogs -i
+ dh_installman -i
dh_link -i
dh_compress -i
dh_fixperms -i
@@ -72,20 +72,20 @@ binary-indep: build install
binary-arch: build install
dh_testdir -a
dh_testroot -a
-# dh_installdebconf -a
+ dh_installchangelogs -a
dh_installdocs -a
dh_installexamples -a
dh_installmenu -a
+# dh_installdebconf -a
# dh_installlogrotate -a
# dh_installemacsen -a
# dh_installpam -a
# dh_installmime -a
# dh_installinit -a
- dh_installcron -a
- dh_installman -a
- dh_installinfo -a
+# dh_installcron -a
+# dh_installinfo -a
# dh_undocumented -a
- dh_installchangelogs -a
+ dh_installman -a
dh_strip -a
dh_link -a
dh_compress -a
diff --git a/examples/rules.multi2 b/examples/rules.multi2
index 4434b0c0..edde0b8d 100755
--- a/examples/rules.multi2
+++ b/examples/rules.multi2
@@ -41,7 +41,7 @@ install: build
# Add here commands to install the package into debian/tmp.
#$(MAKE) prefix=`pwd`/debian/tmp/usr install
- dh_movefiles
+ dh_install
# This single target is used to build all the packages, all at once, or
# one at a time. So keep in mind: any options passed to commands here will
@@ -50,20 +50,21 @@ install: build
binary-common:
dh_testdir
dh_testroot
-# dh_installdebconf
+ dh_installchangelogs
dh_installdocs
dh_installexamples
dh_installmenu
+# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
# dh_installman
- dh_installcron
- dh_installinfo
+# dh_installcron
+# dh_installinfo
# dh_undocumented
- dh_installchangelogs
+ dh_installman
dh_strip
dh_link
dh_compress