summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiels Thykier <niels@thykier.net>2015-09-01 08:52:40 +0200
committerNiels Thykier <niels@thykier.net>2015-09-01 08:52:40 +0200
commit4e3fd5d6e9d5aa94a23a12739bee41a26a17797b (patch)
tree30fa0ef1cd508b9f96420d7289cf7ba2e58509b3
parent2c3ac22e826079f28d5676c3d86a8b8e9a4ec6e7 (diff)
dh_install: Read d/not-installed with --list-missing
Signed-off-by: Niels Thykier <niels@thykier.net>
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_install13
2 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e78e3be6..b815f360 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -39,6 +39,11 @@ debhelper (9.20150811+unreleased) UNRELEASED; urgency=medium
* dh_fixperms: Reset permissions to 0644 for .js, .css,
.jpeg, .jpg, .png, and .gif files. Thanks to Ernesto
Hernández-Novich for the suggestion. (Closes: #595097)
+ * dh_install: Read debian/not-installed if present as a
+ list of files that are deliberately not installed.
+ Files listed here will not cause dh_install to complain
+ with --list-missing. Thanks to Peter Eisentraut for the
+ suggestion. (Closes: #436240)
[ Paul Tagliamonte ]
* dh_gencontrol: Put debug debs back in the "debug" section.
diff --git a/dh_install b/dh_install
index 7f8391e7..9c8d23cb 100755
--- a/dh_install
+++ b/dh_install
@@ -55,6 +55,15 @@ itself, with no explicit destination, then B<dh_install>
will automatically guess the destination to use, the same as if the
--autodest option were used.
+=item debian/not-installed
+
+List the files that are deliberately not installed in any package.
+This is used with B<--list-missing> (or B<--fail-missing>) as an
+exclude file.
+
+Please keep in mind that dh_install will B<not> expand wildcards in
+this file.
+
=back
=head1 OPTIONS
@@ -229,6 +238,10 @@ if ($dh{LIST_MISSING} || $dh{FAIL_MISSING}) {
}
my @missing;
+ if ( -f 'debian/not-installed') {
+ # Pretend that these are also installed.
+ push(@installed, filearray('debian/not-installed'));
+ }
my $installed=join("|", map {
# Kill any extra slashes, for robustness.
y:/:/:s;