summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-05-05 16:11:58 -0400
committerJoey Hess <joey@kitenet.net>2013-05-05 16:11:58 -0400
commit778b1d5f7119622c755278ed163b316e92cd1487 (patch)
tree5204a9bb213e59d083f6bb467c6c94d40b53d54b
parent4aff421d7332ef5791a2b2e271139f63e8e9b649 (diff)
dh_installdeb: Drop pre-dependency on dpkg for dpkg-maintscript-helper. Closes: #703264
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installdeb12
2 files changed, 6 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 181beb01..81343bd1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ debhelper (9.20130505) UNRELEASED; urgency=low
within commands that provide a high-level description of the command.)
* perl_makemaker: Unset INSTALL_BASE in case the user has it set.
Closes: #705141
+ * dh_installdeb: Drop pre-dependency on dpkg for dpkg-maintscript-helper.
+ Closes: #703264
-- Joey Hess <joeyh@debian.org> Sun, 05 May 2013 11:34:20 -0400
diff --git a/dh_installdeb b/dh_installdeb
index bc4091b7..e2331701 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -58,11 +58,6 @@ code cannot be inserted here. For example, a line such as C<mv_conffile
/etc/oldconffile /etc/newconffile> will insert maintainer script snippets
into all maintainer scripts sufficient to move that conffile.
-A versioned Pre-Dependency on dpkg is needed to use
-L<dpkg-maintscript-helper(1)>. An appropriate Pre-Dependency is
-set in ${misc:Pre-Depends} ; you should make sure to put that token into
-an appropriate place in your debian/control file.
-
=back
=cut
@@ -72,8 +67,8 @@ init();
# dpkg-maintscript-helper commands with their associated dpkg pre-dependency
# versions.
my %maintscript_predeps = (
- "rm_conffile" => "1.15.7.2",
- "mv_conffile" => "1.15.7.2",
+ "rm_conffile" => "",
+ "mv_conffile" => "",
);
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -105,7 +100,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
error("unknown dpkg-maintscript-helper command: $cmd")
unless exists $maintscript_predeps{$cmd};
addsubstvar($package, "misc:Pre-Depends", "dpkg",
- ">= $maintscript_predeps{$cmd}");
+ ">= $maintscript_predeps{$cmd}")
+ if length $maintscript_predeps{$cmd};
my $params=escape_shell(@$line);
foreach my $script (qw{postinst preinst prerm postrm}) {
autoscript($package, $script, "maintscript-helper",