summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>1999-09-06 23:35:56 +0000
committerjoey <joey>1999-09-06 23:35:56 +0000
commit7c22a1819a669b43bf20f9ab3d744daec4aca377 (patch)
tree4f93607def58cc50ad9591ef638ef95d25a72e97
parent94373db404c60078e2275ba43bc84b348f27d1a5 (diff)
r268: * dh_installinfo: failed pretty miserably if the info file's section
contained '/' characters. Doesn't now.
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installinfo1
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2ce69c2f..26e97bfc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.0.42) unstable; urgency=low
+
+ * dh_installinfo: failed pretty miserably if the info file's section
+ contained '/' characters. Doesn't now.
+
+ -- Joey Hess <joeyh@master.debian.org> Mon, 6 Sep 1999 16:33:13 -0700
+
debhelper (2.0.41) unstable; urgency=low
* dh_installinfo: use FHS info dir. I wonder how I missed that..
diff --git a/dh_installinfo b/dh_installinfo
index 55deb362..fe03433b 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -48,6 +48,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
my $fn="/usr/share/info/".Dh_Lib::basename($file);
if ($section ne '') {
+ $section=~s:/:\\/:g; # allow / in section.
autoscript($PACKAGE,"postinst","postinst-info",
"s/#SECTION#/$section/g;s:#FILE#:$fn:");
}