summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2006-11-07 22:10:35 +0000
committerjoeyh <joeyh>2006-11-07 22:10:35 +0000
commit860d0141f7d983a137621ae99be697c079af1ecf (patch)
tree5e30c22718666d7f5c7b89f77dad5a099306091c
parentf97dde5096608119aa86239edcce2b5532645a3b (diff)
r1956: * Correct some incorrect instances of "v4 only" in docs. Closes: #381536
* dh_installinfo: Put the section madness to bed by not passing any section information to install-info. Current install-info parses INFO-DIR-SECTION on its own if that's not specified. Closes: #337215
-rw-r--r--autoscripts/postinst-info2
-rw-r--r--autoscripts/postinst-info-nosection3
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_fixperms2
-rwxr-xr-xdh_installinfo30
-rwxr-xr-xdh_link4
6 files changed, 14 insertions, 33 deletions
diff --git a/autoscripts/postinst-info b/autoscripts/postinst-info
index b528b5d8..ffef8636 100644
--- a/autoscripts/postinst-info
+++ b/autoscripts/postinst-info
@@ -1,3 +1,3 @@
if [ "$1" = "configure" ]; then
- install-info --quiet --section "\Q#SECTION#\E" "#SECTION#" #FILE#
+ install-info --quiet #FILE#
fi
diff --git a/autoscripts/postinst-info-nosection b/autoscripts/postinst-info-nosection
deleted file mode 100644
index ffef8636..00000000
--- a/autoscripts/postinst-info-nosection
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ "$1" = "configure" ]; then
- install-info --quiet #FILE#
-fi
diff --git a/debian/changelog b/debian/changelog
index 24f7e662..33d20d5e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,8 +11,12 @@ debhelper (5.0.41) UNRELEASED; urgency=low
* Tighten python-support and python-central dependencies of debhelper,
in an IMHO rather futile attempt to deal with derived distributions.
Closes: #395495
+ * Correct some incorrect instances of "v4 only" in docs. Closes: #381536
+ * dh_installinfo: Put the section madness to bed by not passing any section
+ information to install-info. Current install-info parses INFO-DIR-SECTION
+ on its own if that's not specified. Closes: #337215
- -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 13:35:38 -0400
+ -- Joey Hess <joeyh@debian.org> Tue, 7 Nov 2006 17:04:47 -0500
debhelper (5.0.40) unstable; urgency=medium
diff --git a/dh_fixperms b/dh_fixperms
index 2a565bd3..775ab55e 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -85,7 +85,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
"-perm -5 -name '*.pm' $find_options -print0",
"2>/dev/null | xargs -0r chmod a-X");
- # v4 only
+ # v4 and up
if (! compat(3)) {
# Programs in the bin and init.d dirs should be executable..
for my $dir (qw{usr/bin bin usr/sbin sbin usr/games etc/init.d}) {
diff --git a/dh_installinfo b/dh_installinfo
index 78dddc7b..07760cc5 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -18,9 +18,9 @@ B<dh_installinfo> [S<I<debhelper options>>] [B<-A>] [B<-n>] [S<I<file ...>>]
dh_installinfo is a debhelper program that is responsible for installing
info files and registering the files it installs with install-info.
-It determines some information about the info files by parsing them, in
-particular, it looks at the INFO-DIR-SECTION line to determine what section
-the info file belongs in.
+Note that install-info determines some information about the info files by
+parsing them, in particular, it looks at the INFO-DIR-SECTION line to
+determine what section the info file belongs in.
Any filenames specified as parameters will be installed into the first
package dh_installinfo is told to act on. By default, this is the first
@@ -90,30 +90,10 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Only register with install-info if this is a head file in
# a tree of info files.
if ($file !~ /-\d+$/ && ! $dh{NOSCRIPTS}) {
- # Figure out what section this file goes in.
- my $section='';
- open (IN, "<$file") || die "$file: $!";
- while (<IN>) {
- if (/INFO-DIR-SECTION\s+(.*)/) {
- $section=$1;
- last;
- }
- }
- close IN;
-
my $fn="/usr/share/info/".basename($file);
- if ($section ne '') {
- $section=~s:/:\\/:g; # allow / in section.
- $section=~s/\&/\\&/g; # escape sed specials
- $section=~s/(\\[0-9])/\\\\$1/g; # more sed specials
- autoscript($package,"postinst","postinst-info",
- "s/#SECTION#/$section/g;s:#FILE#:$fn:");
- }
- else {
- autoscript($package,"postinst","postinst-info-nosection",
- "s:#FILE#:$fn:");
- }
+ autoscript($package,"postinst","postinst-info",
+ "s:#FILE#:$fn:");
autoscript($package,"prerm","prerm-info", "s:#FILE#:$fn:");
}
}
diff --git a/dh_link b/dh_link
index e5413ecb..f7a910a5 100755
--- a/dh_link
+++ b/dh_link
@@ -43,7 +43,7 @@ a path as possible. It will also create any subdirectories it needs to to put
the symlinks in.
dh_link also scans the package build tree for existing symlinks which do not
-conform to debian policy, and corrects them (v4 only).
+conform to debian policy, and corrects them (v4 or later).
=head1 OPTIONS
@@ -138,7 +138,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
error("parameters list a link without a destination.");
}
- # v4 only and only if there is a temp dir already
+ # v4 or later and only if there is a temp dir already
if (! compat(3) && -e $tmp) {
# Scan for existing links and add them to @links, so they
# are recreated policy conformant.