summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-07-25 13:40:39 -0400
committerJoey Hess <joey@kitenet.net>2010-07-25 13:40:39 -0400
commit865e6266a5eaae81004bf530bc23da1c3fdc10b1 (patch)
tree5aa063427dedd8cbc9406c6cf1e352268a4bf51f
parenteb9464fb4bbea788f2703a9bb3314dcd9fe2e0d5 (diff)
python_distutils: Pass --force to setup.py build, to ensure that when python-dbg is run it does not win and result in scripts having it in the shebang line. Closes: #589759
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm4
-rw-r--r--debian/changelog6
2 files changed, 9 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 70307b0f..5115a8ae 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -163,7 +163,9 @@ sub setup_py {
sub build {
my $this=shift;
- $this->setup_py("build", @_);
+ $this->setup_py("build",
+ "--force",
+ @_);
}
sub install {
diff --git a/debian/changelog b/debian/changelog
index c895d780..6a1ca77f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,13 @@
debhelper (7.9.4) UNRELEASED; urgency=low
+ [ Carsten Hey ]
* dh_fixperms: Ensure files in /etc/sudoers.d/ are mode 440. Closes: #589574
+ [ Joey Hess ]
+ * python_distutils: Pass --force to setup.py build, to ensure that when
+ python-dbg is run it does not win and result in scripts having it in
+ the shebang line. Closes: #589759
+
-- Carsten Hey <carsten@debian.org> Sun, 18 Jul 2010 22:30:06 +0200
debhelper (7.9.3) unstable; urgency=low