summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-07-15 12:29:32 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-07-15 12:29:32 -0400
commitd6daf9d873db059f0fab473b8f095ba4217ea154 (patch)
tree1f0d7df910e12b0b24adfd404f73047c9332b676
parent5a4f5a4379f537f7a7a3efca3e251ad16f217e8e (diff)
dh_installchangelogs: When searching for changelog in v7 mode, skip empty files. Closes: #490937
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installchangelogs2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8a77d628..4e6ed7c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
debhelper (7.0.16) UNRELEASED; urgency=low
* dh: Avoid passing --with on to subcommands. Closes: #490886
+ * dh_installchangelogs: When searching for changelog in v7 mode, skip
+ empty files. Closes: #490937
-- Joey Hess <joeyh@debian.org> Mon, 14 Jul 2008 20:35:47 -0400
diff --git a/dh_installchangelogs b/dh_installchangelogs
index fc0b91d7..7042c5f9 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -69,7 +69,7 @@ if (! defined $upstream) {
if (! isnative($dh{MAINPACKAGE}) && !compat(6)) {
my @files=sort glob("*");
foreach my $name (qw{changelog changes}) {
- my @matches=grep { lc $_ eq $name } @files;
+ my @matches=grep { lc $_ eq $name && -s $_ } @files;
if (@matches) {
$upstream=shift @matches;
last;