summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/cmake.pm
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-11-19 20:58:39 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-11-19 14:52:14 -0500
commit25d57ca95f7571e13dbba4a0ae82c43d5e0e5a06 (patch)
tree29562b57dade5f82710da21031a4a4e840592d7c /Debian/Debhelper/Buildsystem/cmake.pm
parentb473ba8f7c4eb5084c71362b4e04133dda3e62ec (diff)
cmake build+ steps need Makefile.
The condition is not what dh_auto_* 7.0.x would have done. The patch makes auto-selection to pass through cmake.pm if Makefile was not created. This problem is not very dangerous though.
Diffstat (limited to 'Debian/Debhelper/Buildsystem/cmake.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm5
1 files changed, 3 insertions, 2 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index ee90c1f9..24f486fc 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -17,12 +17,13 @@ sub check_auto_buildable {
my $this=shift;
my ($step)=@_;
if (-e $this->get_sourcepath("CMakeLists.txt")) {
- my $ret = $this->SUPER::check_auto_buildable(@_);
+ my $ret = ($step eq "configure" && 1) ||
+ $this->SUPER::check_auto_buildable(@_);
# Existence of CMakeCache.txt indicates cmake has already
# been used by a prior build step, so should be used
# instead of the parent makefile class.
$ret++ if ($ret && -e $this->get_buildpath("CMakeCache.txt"));
- return $ret > 0 ? $ret : 1;
+ return $ret;
}
return 0;
}