summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/python_distutils.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-06-28 15:01:04 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-06-28 15:01:04 -0400
commite0ed03ff224ee3a8053094f02bcd02d4dd3fa358 (patch)
tree985fc37dc455372b3857a6d302860bcbf4b5bbdb /Debian/Debhelper/Buildsystem/python_distutils.pm
parent55a176113de2b1923c62774779bb9e069d88021d (diff)
Revert "Update dh_auto documentation."
I'm reverting the documentation addition to try doing it myself, more simply and less verbosely. This reverts commit 962a2e10c930e3504ea1c0327be2fdf70d53023e. Conflicts: dh_auto.pod
Diffstat (limited to 'Debian/Debhelper/Buildsystem/python_distutils.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm129
1 files changed, 0 insertions, 129 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 5a04d4e6..46f4c1c1 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -7,37 +7,6 @@
package Debian::Debhelper::Buildsystem::python_distutils;
-=head1 NAME
-
-B<python_distutils> - Python Distutils (setup.py)
-
-=head1 SYNOPSIS
-
-B<dh_auto_*> [B<--buildsystem>=I<python_distutils>] ...
-
-=head1 DESCRIPTION
-
-Python Distribution Utilities (Distutils for short) is a standard Python build
-system. It is used to package most of the Python modules in the source
-distribution form. Typically, only two steps (build and install) are needed to
-finish installation of the Distutils based Python module. This build system can
-be typically identified by presence of the F<setup.py> in the source directory.
-
-=head1 DH_AUTO NOTES
-
-Out of source tree building is done by default but in source building is also
-supported. PLEASE NOTE that B<default build directory> is B<$srcdir/build>
-where $srcdir is a path to the source directory.
-
-Due to design flaws of Distutils, it is not possible to set a B<custom> build
-directory via command line arguments to F<setup.py>. Therefore, the same effect
-is achieved by writing appropriate F<.pydistutils.cfg> file to the build
-directory and pointing $HOME environment variable to the build directory.
-
-=head1 BUILD PROCESS
-
-=cut
-
use strict;
use Cwd ();
use Debian::Debhelper::Dh_Lib qw(error);
@@ -112,104 +81,17 @@ sub setup_py {
$this->doit_in_sourcedir("python", "setup.py", $act, @_);
}
-=head2 Configure step
-
-=over 4
-
-=item I<Behaviour>
-
-Do nothing but stop auto-selection process.
-
-=item I<Auto-selection>
-
-If neither F<configure>, F<Makefile.PL> exist, but F<setup.py> exists in the
-source directory.
-
-=back
-
-=cut
-
-=head2 Build step
-
-=over 4
-
-=item I<Behaviour>
-
-Execute C<python setup.py build>.
-
-=item I<Auto-selection>
-
-If F<Makefile>, F<makefile> F<GNUmakefile> do not exist in the build directory
-and F<setup.py> file exists in the source directory.
-
-=back
-
-=cut
sub build {
my $this=shift;
$this->setup_py("build", @_);
}
-=head2 Test step
-
-=over 4
-
-=item I<Behaviour>
-
-Do nothing but stop auto-selection process.
-
-=item I<Auto-selection>
-
-F<Makefile>, F<makefile>, F<GNUmakefile> do not exist in the build directory and
-F<setup.py> file exists in the source directory.
-
-=back
-
-=cut
-
-=head2 Install step
-
-=over 4
-
-=item I<Behaviour>
-
-Execute C<python setup.py install> passing temporary installation directory via
-C<--root> parameter. C<--no-compile> and C<-O0> parameters are also passed by
-default. See L<dh_auto_install(1)> for more information.
-
-=item I<Auto-selection>
-
-F<Makefile>, F<makefile>, F<GNUmakefile> do not exist in the build directory and
-F<setup.py> file exists in the source directory.
-
-=back
-
-=cut
sub install {
my $this=shift;
my $destdir=shift;
$this->setup_py("install", "--root=$destdir", "--no-compile", "-O0", @_);
}
-=head2 Clean step
-
-=over 4
-
-=item I<Behaviour>
-
-Execute C<python setup.py clean -a>. Additional parameters (if specified) are
-passed to the latter command. F<.pydistutils.cfg> is also removed if it was
-created (together with the build directory if it is ends up empty). Finally,
-recursively find and delete all *.pyc files from the source directory.
-
-=item I<Auto-selection>
-
-F<Makefile>, F<makefile>, F<GNUmakefile> do not exist in the build directory and
-F<setup.py> file exists in the source directory.
-
-=back
-
-=cut
sub clean {
my $this=shift;
$this->setup_py("clean", "-a", @_);
@@ -224,15 +106,4 @@ sub clean {
$this->doit_in_sourcedir('find', '.', '-name', '*.pyc', '-exec', 'rm', '{}', ';');
}
-=head1 SEE ALSO
-
-L<dh_auto(7)>
-
-=head1 AUTHORS
-
- Joey Hess <joeyh@debian.org>
- Modestas Vainius <modestas@vainius.eu>
-
-=cut
-
1;