summaryrefslogtreecommitdiff
path: root/dh_auto_configure
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-23 14:08:49 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-23 14:08:49 -0400
commitc251bfd3e5033243aaa9e50c753299bc19602733 (patch)
treee64be97207364075ef2229efac3f15b1b3c80e3e /dh_auto_configure
parent935ad398869a2f9a2f8ad032290588029e9ed818 (diff)
dh_auto_build: New program, automates building the package by either running make or using setup.py. (Support for cmake and other build systems planned but not yet implemented.)
Diffstat (limited to 'dh_auto_configure')
-rwxr-xr-xdh_auto_configure7
1 files changed, 2 insertions, 5 deletions
diff --git a/dh_auto_configure b/dh_auto_configure
index 27f9065c..4b01889b 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -23,7 +23,7 @@ is found, dh_auto_configure will exit without doing anything.
This is intended to work for about 90% of packages. If it doesn't work,
you're encoruaged to skip using dh_auto_configure at all, and just run
-./configure or its equivilant by hand.
+./configure or its equivilant manually.
=head1 OPTIONS
@@ -85,10 +85,7 @@ if (-x "configure") {
doit("./configure", @opts, @{$dh{U_PARAMS}});
}
elsif (-e "Makefile.PL") {
- doit("perl Makefile.PL", "INSTALLDIRS=vendor", @{$dh{U_PARAMS}});
-}
-elsif (-e "setup.py") {
- doit("python setup.py", "build", @{$dh{U_PARAMS}});
+ doit("perl", "Makefile.PL", "INSTALLDIRS=vendor", @{$dh{U_PARAMS}});
}
=head1 SEE ALSO