summaryrefslogtreecommitdiff
path: root/dh_lib
diff options
context:
space:
mode:
authorjoey <joey>1999-08-17 05:05:44 +0000
committerjoey <joey>1999-08-17 05:05:44 +0000
commitaced3d9f3589e56fca0354cc4be7d1a9ee664954 (patch)
tree6aef17f472cfeba303b70631c255de9b386837e7 /dh_lib
parentb685b3d0a30841511e1d84e3cf5e658a8eff5119 (diff)
r178: Removed
Diffstat (limited to 'dh_lib')
-rw-r--r--dh_lib50
1 files changed, 0 insertions, 50 deletions
diff --git a/dh_lib b/dh_lib
deleted file mode 100644
index d9266395..00000000
--- a/dh_lib
+++ /dev/null
@@ -1,50 +0,0 @@
-# Library functions for debhelper programs.
-
-# Run a command, and display the command to stdout if verbose mode is on.
-# All commands that edit debian/tmp should be ran via this function.
-function doit() {
- verbose_echo "$1"
- $1
-}
-
-# Echo something if the verbose flag is on.
-function verbose_echo() {
- if [ "$DH_VERBOSE" ]; then
- echo " $1"
- fi
-}
-
-# Echo an error message and exit.
-function error() {
- echo `basename $0`": $1" >&2
- exit 1
-}
-
-# Argument processing and global variable initialization is below.
-
-# Get the package name and version from the changelog.
-LINE=`head -1 debian/changelog`
-PACKAGE=`expr "$LINE" : '\(.*\) (.*)'`
-VERSION=`expr "$LINE" : '.* (\(.*\))'`
-
-# Is this a native Debian package?
-if ! expr "$VERSION" : '.*-' >/dev/null; then
- NATIVE=1
-fi
-
-# Parse command line.
-set -- `getopt v $*`
-
-for i; do
- case "$i"
- in
- -v)
- DH_VERBOSE=1
- shift
- ;;
- --)
- shift
- break
- ;;
- esac
-done