summaryrefslogtreecommitdiff
path: root/dh_listpackages
diff options
context:
space:
mode:
authorAurelien Jarno <aurel32@debian.org>2023-08-14 21:07:54 +0200
committerAurelien Jarno <aurel32@debian.org>2023-08-14 21:07:54 +0200
commit259ab8a0d17d9846ae80a157b6636e9d22be131a (patch)
tree8ee3751f62004a10458ece2ef29566b356bcaeac /dh_listpackages
parent76669f0e65fa2b7bf70d2a1293be591c38d0caba (diff)
parent2998eb8dfc6d0e62ad0269ff9184d2ef1c334196 (diff)
Record debhelper (13.11.5) in archive suite sid
Diffstat (limited to 'dh_listpackages')
-rwxr-xr-xdh_listpackages10
1 files changed, 7 insertions, 3 deletions
diff --git a/dh_listpackages b/dh_listpackages
index 109301b9..e43e2cdb 100755
--- a/dh_listpackages
+++ b/dh_listpackages
@@ -1,4 +1,4 @@
-#!/usr/bin/perl -w
+#!/usr/bin/perl
=head1 NAME
@@ -7,8 +7,11 @@ dh_listpackages - list binary packages debhelper will act on
=cut
use strict;
+use warnings;
use Debian::Debhelper::Dh_Lib;
+our $VERSION = DH_BUILTIN_VERSION;
+
=head1 SYNOPSIS
B<dh_listpackages> [S<I<debhelper options>>]
@@ -20,11 +23,12 @@ packages debhelper commands will act on. If you pass it some options, it
will change the list to match the packages other debhelper commands would
act on if passed the same options.
+Packages are listed in the order they appear in F<debian/control>.
+
=cut
$dh{BLOCK_NOOP_WARNINGS}=1;
-init();
-inhibit_log();
+init(inhibit_log => 1);
print join("\n",@{$dh{DOPACKAGES}})."\n";
=head1 SEE ALSO